Przejdź do głównej zawartości
  • Szybkie i łatwe składanie zamówień
  • Wyświetlanie zamówień i śledzenie stanu wysyłki
  • Tworzenie i dostęp do listy produktów
  • Na firmowej stronie administracji możesz zarządzać witrynami, produktami i danymi kontaktowymi firmy Dell EMC.

如何在戴尔计算机上修复 Windows 操作系统的 GPT 硬盘上的 EFI 启动加载程序

Podsumowanie: 本文提供如何解决 GPT 硬盘驱动器上 EFI 引导加载程序无法正确引导的问题的相关信息。它包括适用于各种 Windows 操作系统的说明。

Ten artykuł mógł zostać automatycznie przetłumaczony. Jeśli masz uwagi na temat jego jakości, przekaż je nam, korzystając z formularza u dołu tej strony.

Treść artykułu


Objawy

Przyczyna

简介

 

在 Windows 操作系统上遇到引导问题的大多数用户会选择重新安装操作系统而不是尝试修复引导问题。

这篇文章介绍如何在 GUID [Globally Unique Identifiers] 分区表 (GPT) 硬盘驱动器上修复可扩展固件接口 (EFI) 启动加载程序。

此解决方案仅适用于安装在统一可扩展固件接口 (UEFI) 基本输入/输出系统 (BIOS) 上的操作系统。


返回页首


Rozwiązanie

如何修复您的EFI引导加载程序

 

Windows 7 和 Windows 8 通常安装在使用 Main Boot Record (MBR) 的传统 BIOS 上。但是,Windows 11 和 Windows 10 设计为使用 EFI 启动加载程序和 GPT 安装在 UEFI BIOS 上。

提醒:尝试修复硬盘的根目录可能会导致硬盘上先前未备份的所有数据丢失。最佳实践是务必在对任何硬盘或其操作系统执行操作之前完整备份硬盘。

GPT 结构可以解决 MBR 中 Bootsect 命令用于解决的大部分问题。但是,以下说明将指导您修复 EFI 引导加载程序:

Windows 11

如果您安装介质:

  1. 将介质 (DVD/USB) 放入您的个人计算机中,然后重新启动

  2. 从介质引导。

  3. 选择Repair Your Computer(修复计算机)。

  4. 选择疑难解答

  5. 选择高级选项

  6. 从菜单中选择命令提示符

    1. 输入并运行以下命令:

      diskpart

    2. 输入并运行以下命令:

      select disk 0

    3. 输入并运行以下命令:

      list vol

  7. 验证 EFI 分区(EPS — EFI 系统分区)是否在使用 FAT32 文件系统。为尚未使用的分区指定驱动器盘符:

    1. 输入并运行以下命令:

      select vol

    2. 输入并运行以下命令:

      assign letter=

    3. 输入并运行以下命令:

      exit

 
提醒:请查看此部分说明末尾的信息。
 

如果您没有安装介质:

  1. 使用本文中的一种方法启动至 Windows Advanced Boot Options 菜单:

  2. 从随后出现的菜单中,选择修复计算机

  3. Troubleshoot 屏幕中,从 Advanced Options 选项卡中选择 Command Prompt

    1. 输入并运行以下命令:

      diskpart

    2. 输入并运行以下命令:

      select disk 0

    3. 输入并运行以下命令:

      list vol

  4. 验证 EFI 分区 (EPS) 使用的是 FAT32 文件系统并为其分配一个尚未使用的驱动器盘符:

    1. 输入并运行以下命令:

      select vol

    2. 输入并运行以下命令:

      assign letter=

    3. 输入并运行以下命令:

      exit

  5. 要修复启动记录:

    1. 输入并运行以下命令:

      cd /d :\EFI\Microsoft\Boot\

    2. 输入并运行以下命令:

      bootrec /FixBoot

Windows 10

如果您安装介质:

  1. 将介质 (DVD/USB) 放入您的个人计算机中,然后重新启动

  2. 从介质引导。

  3. 选择Repair Your Computer(修复计算机)。

  4. 选择疑难解答

  5. 选择高级选项

  6. 从菜单中选择命令提示符

    1. 输入并运行以下命令:

      diskpart

    2. 输入并运行以下命令:

      sel disk 0

    3. 输入并运行以下命令:

      list vol

  7. 验证 EFI 分区(EPS — EFI 系统分区)是否在使用 FAT32 文件系统。为尚未使用的分区指定驱动器盘符:

    1. 输入并运行以下命令:

      sel vol

    2. 输入并运行以下命令:

      assign letter :

    3. 输入并运行以下命令:

      exit

提醒:如果您正在运行 Windows 10(版本 1709 或更高版本),请忽略步骤 8,并转至本说明部分末尾的信息。
 
  1. 要修复启动记录:

    1. 输入并运行以下命令:

      cd /d :\EFI\Microsoft\Boot\

    2. 输入并运行以下命令:

      bootrec /FixBoot

 

如果您没有安装介质:

  1. 使用本文中的一种方法启动至 Windows Advanced Boot Options 菜单:

  2. 从随后出现的菜单中,选择修复计算机

  3. Troubleshoot 屏幕中,从 Advanced Options 选项卡中选择 Command Prompt

    1. 输入并运行以下命令:

      diskpart

    2. 输入并运行以下命令:

      sel disk 0

    3. 输入并运行以下命令:

      list vol

  4. 验证 EFI 分区 (EPS) 使用的是 FAT32 文件系统并为其分配一个尚未使用的驱动器盘符:

    1. 输入并运行以下命令:

      sel vol

    2. 输入并运行以下命令:

      assign letter=:

    3. 输入并运行以下命令:

      exit

  5. 要修复启动记录:

    1. 输入并运行以下命令:

      cd /d :\EFI\Microsoft\Boot\

    2. 输入并运行以下命令:

      bootrec /FixBoot

Windows 8和8.1

如果您安装介质:

  1. 将介质 (DVD/USB) 放入您的个人计算机中,然后重新启动

  2. 从介质引导。

  3. 选择Repair Your Computer(修复计算机)。

  4. 选择疑难解答

  5. 从菜单中选择命令提示符

    1. 输入并运行以下命令:

      diskpart

    2. 输入并运行以下命令:

      sel disk 0

    3. 输入并运行以下命令:

      list vol

  6. 验证 EFI 分区(EPS — EFI 系统分区)是否在使用 FAT32 文件系统。为它指定驱动器盘符(指定某个尚未使用的盘符。):

    1. 输入并运行以下命令:

      sel vol

    2. 输入并运行以下命令:

      assign letter=:

    3. 输入并运行以下命令:

      exit

  7. 要修复启动记录:

    1. 输入并运行以下命令:

      cd /d :\EFI\Microsoft\Boot\

    2. 输入并运行以下命令:

      bootrec /FixBoot

如果您没有安装介质:

  1. 重新启动您的个人计算机。

  2. 在个人计算机打开之后,但是在出现 Windows 闪屏之前,快速点击 F8> 键。

    请注意,这可能需要多次尝试。此选项需时比 Windows 7 中相同选项需时缩短。

  3. 从随后出现的菜单中,选择修复计算机

  4. 故障处理屏幕中选择命令提示符

    1. 输入并运行以下命令:

      diskpart

    2. 输入并运行以下命令:

      sel disk 0

    3. 输入并运行以下命令:

      list vol

  5. 验证 EFI 分区 (EPS) 是否在使用 FAT32 文件系统。为它指定驱动器盘符(指定某个尚未使用的盘符。):

    1. 输入并运行以下命令:

      sel vol

    2. 输入并运行以下命令:

      assign letter=:

    3. 输入并运行以下命令:

      exit

  6. 要修复启动记录:

    1. 输入并运行以下命令:

      cd /d :\EFI\Microsoft\Boot\

    2. 输入并运行以下命令:

      bootrec /FixBoot

Windows 7

如果您安装介质:

  1. 将介质 (DVD/USB) 放入您的个人计算机中,然后重新启动

  2. 从介质引导。

  3. 选择Repair Your Computer(修复计算机)。

  4. 选择操作系统,然后单击下一步

  5. 从菜单中选择命令提示符

    1. 输入并运行以下命令:

      diskpart

    2. 输入并运行以下命令:

      sel disk 0

    3. 输入并运行以下命令:

      list vol

  6. 验证 EFI 分区(EPS — EFI 系统分区)是否在使用 FAT32 文件系统。为尚未使用的分区指定驱动器盘符:

    1. 输入并运行以下命令:

      sel vol

    2. 输入并运行以下命令:

      assign letter=:

    3. 输入并运行以下命令:

      exit

  7. 要修复启动记录:

    1. 输入并运行以下命令:

      cd /d :\EFI\Microsoft\Boot\

    2. 输入并运行以下命令:

      bootrec /FixBoot

如果您没有安装介质:

  1. 重新启动您的个人计算机。

  2. 在个人计算机打开之后,但是在出现 Windows 闪屏之前,快速点击 F8> 键。

  3. 从随后出现的菜单中,选择修复计算机

  4. 恢复选项中选择命令提示符

    1. 输入并运行以下命令:

      diskpart

    2. 输入并运行以下命令:

      sel disk 0

    3. 输入并运行以下命令:

      list vol

  5. 验证 EFI 分区 (EPS) 使用的是 FAT32 文件系统并为其分配一个尚未使用的驱动器盘符:

    1. 输入并运行以下命令:

      sel vol

    2. 输入并运行以下命令:

      assign letter=:

    3. 输入并运行以下命令:

      exit

  6. 要修复启动记录:

    1. 输入并运行以下命令:

      cd /d :\EFI\Microsoft\Boot\

    2. 输入并运行以下命令:

      bootrec /FixBoot

Windows 11 和 Windows 10(版本 1709 及更高版本):

  1. 重建 BCD 存储。

    1. 先运行下面的命令以备份旧的 BCD:

      ren BCD BCD.bak

    2. 现在使用此命令重建 BCD:

      bcdboot c:\Windows /s : /f ALL(您可以在 /s 之前为计算机语言环境添加交换机:/l 。默认情况下,使用 /l en-us 英语 USA。)

    3. bootrec /rebuildbcd

Windows 10(版本 1709 之前)、Windows 8 和 Windows 7:

  1. 重建 BCD 存储。

    1. 先运行下面的命令以备份旧的 BCD:

      ren BCD BCD.old

    2. 现在使用此命令重建 BCD:

      bcdboot c:\Windows /l en-us /s : All


返回页首


 

如何修复主启动记录 (MBR)

 

这些步骤适用于在任何最新 Windows 操作系统上用作启动驱动器的任何旧式驱动器。

  1. 在出现戴尔启动画面时,使用 F12 键以进入启动菜单。它使您可以从 Windows 安装介质或可启动光盘或闪存驱动器进行启动。

  2. 单击立即安装屏幕底部的修复计算机链接。

  3. 单击故障处理

  4. 选择命令提示符

  5. 依次输入以下三个命令,每输入一个命令按一下 Enter 键:

    bootrec /fixmbr

    bootrec /fixboot

    bootrec /rebuildbcd

  6. 移除安装介质后重新启动计算机,以检查修复是否起作用。

 

如果您需要更多帮助,请联系技术支持。

 

  与我们联系  


返回页首


Dodatkowe informacje

推荐的文章

以下是您可能会感兴趣的与此主题相关的一些推荐文章。


超出保修期支持超出保修期?没有问题。浏览 Dell.com/support 网站,输入您的戴尔服务编号并查看我们的服务。

提醒:服务仅适用于美国加拿大英国法国德国中国大陆地区日本的个人计算机客户。服务器和存储不适用。

Właściwości artykułu


Produkt, którego dotyczy problem

Inspiron, Latitude, Vostro, XPS, Fixed Workstations

Data ostatniej publikacji

27 kwi 2023

Wersja

13

Typ artykułu

Solution