Dell Unity: Příkaz ls zamrzl na klientovi RHEL 8.4 při připojení exportu Unity NFS prostřednictvím NFSv4 (oprava uživatelem)

Podsumowanie: Příkaz ls zamrzl na klientovi RHEL 8.4 při připojení exportu Unity NFS prostřednictvím NFSv4.

Ten artykuł dotyczy Ten artykuł nie dotyczy Ten artykuł nie jest powiązany z żadnym konkretnym produktem. Nie wszystkie wersje produktu zostały zidentyfikowane w tym artykule.

Objawy

Příkaz ls na klientovi Linux zamrzl. K problému dochází pouze u klienta RHEL 8.4 s verzí jádra starší než kernel-4.18.0-305.17.1.el8_4. 
 

Przyczyna

Problém je způsoben interakcí mezi serverem Unity NFS a klienty RHEL 8.4 s jádrem starším než kernel-4.18.0-305.17.1.el8_4.  Když server NFS odesílá nenulového ověřovače v odpovědi READDIR, klient NFS nadále odešle hodnotu 0 pro ověření souboru cookie v následném hovoru READDIR.  Výsledkem je nekonečná smyčka READDIR, která způsobí, že příkaz ls bude vždy viset. 

Rozwiązanie

Zástupné řešení: 
– Připojení exportu nfs prostřednictvím NFSv3.

Trvalá oprava:

- Z klientské strany je chybový procesor opraven v jádru 4.18.0-305.17.1.el8_4.

Podrobnosti naleznete ve verzi systému RHEL. 


https://access.redhat.com/errata/RHSA-2021:3447Klient NFS zamrzá na seznamu sdílených položek, když jsou implementováni ověřovatelé čtení na straně serveru (BZ#1993895)

K tomuto problému je také k dispozici článek databáze znalostí Redhat.



https://access.redhat.com/solutions/6189341 technický tým společnosti Dell Unity také zkoumá budoucí vylepšení kódu, která tento problém dále řeší. Jakmile bude k dispozici aktualizace, aktualizace se aktualizuje.

Produkty, których dotyczy problem

Dell EMC Unity
Właściwości artykułu
Numer artykułu: 000202521
Typ artykułu: Solution
Ostatnia modyfikacja: 27 lip 2023
Wersja:  4
Znajdź odpowiedzi na swoje pytania u innych użytkowników produktów Dell
Usługi pomocy technicznej
Sprawdź, czy Twoje urządzenie jest objęte usługą pomocy technicznej.