Dell VNX: Nie można połączyć się z interfejsem GUI Unisphere po aktualizacji Java (możliwość naprawienia przez użytkownika)
Podsumowanie: Po zaktualizowaniu języka Java do najnowszej wersji unisphere może przestać łączyć się prawidłowo.
Ten artykuł dotyczy
Ten artykuł nie dotyczy
Ten artykuł nie jest powiązany z żadnym konkretnym produktem.
Nie wszystkie wersje produktu zostały zidentyfikowane w tym artykule.
Objawy
Język Java uruchamia się, ale okno logowania Unisphere nigdy nie jest wyświetlane.
Przyczyna
Oracle zmieniło ustawienie języka Java, aby domyślnie wyłączyć TLSv1 i TLSv1.1. Oba algorytmy są nadal wymagane przez VNX Unisphere do prawidłowego otwarcia graficznego interfejsu użytkownika. Ten problem zaobserwowano po raz pierwszy w wersji Java 1.8.0_291, ale może również występować w innych wersjach.
Rozwiązanie
Czynności umożliwiające ponowne włączenie protokołu TLSv1 i TLSv1.1:
1. Przejdź do folderu "lib\security" ścieżki Java (np. "C:\Program Files (x86)\Java\jre1.8.0_291\lib\security").
2. Otwórz plik java.security z uprawnieniami administratora.
3. Wyszukaj ten parametr jdk.tls.disabledAlgorithms
4. Edytuj wiersz, aby usunąć TLSv1 i TLSv1.1
przed
jdk.tls.disabledAlgorithms=SSLv3, TLSv1, TLSv1.1, RC4, DES, MD5withRSA
po
jdk.tls.disabledAlgorithms=SSLv3, RC4, DES, MD5withRSA
5. Zapisz plik.
6. Wyczyść pamięć podręczną przeglądarki i pliki cookie.
7. Uruchom ponownie przeglądarkę i spróbuj ponownie otworzyć Aplikację Unisphere. Powinno działać prawidłowo.
1. Przejdź do folderu "lib\security" ścieżki Java (np. "C:\Program Files (x86)\Java\jre1.8.0_291\lib\security").
2. Otwórz plik java.security z uprawnieniami administratora.
3. Wyszukaj ten parametr jdk.tls.disabledAlgorithms
4. Edytuj wiersz, aby usunąć TLSv1 i TLSv1.1
przed
jdk.tls.disabledAlgorithms=SSLv3, TLSv1, TLSv1.1, RC4, DES, MD5withRSA
po
jdk.tls.disabledAlgorithms=SSLv3, RC4, DES, MD5withRSA
5. Zapisz plik.
6. Wyczyść pamięć podręczną przeglądarki i pliki cookie.
7. Uruchom ponownie przeglądarkę i spróbuj ponownie otworzyć Aplikację Unisphere. Powinno działać prawidłowo.
Produkty, których dotyczy problem
VNX/VNXe, VNX1 Series, VNX2 SeriesProdukty
VNX5100, VNX5200, VNX5300, VNX5400, VNX5500, VNX5600, VNX5700, VNX5800, VNX7500, VNX7600, VNX8000Właściwości artykułu
Numer artykułu: 000202925
Typ artykułu: Solution
Ostatnia modyfikacja: 05 sty 2023
Wersja: 2
Znajdź odpowiedzi na swoje pytania u innych użytkowników produktów Dell
Usługi pomocy technicznej
Sprawdź, czy Twoje urządzenie jest objęte usługą pomocy technicznej.