AppSync: Upgrade Postgres se nezdařil

Resumo: AppSync: Upgrade Postgres se nezdařil

Este artigo aplica-se a Este artigo não se aplica a Este artigo não está vinculado a nenhum produto específico. Nem todas as versões do produto estão identificadas neste artigo.

Sintomas

Postgres se upgraduje podle KB 000504125 a Postgres se nepodaří upgradovat.

Na appsync_dbupgrade.log se zobrazí:
 

Command.run(): C:\Users\userid\AppData\Local\Temp\2\011266.tmp\executeScriptTmp0.bat:stdout [Failure, exiting]
Command.complete(): proces dokončen s ukončovacím kódem: 1


Na pg_upgrade_utility.log se zobrazí:
 

command: xcopy /e /y /q /r "E:\EMC\AppSync\jboss\datastore\data/pg_clog" "E:\EMC\AppSync\NewDatastore\data/pg_clog\" >> "pg_upgrade_utility.log" 2>&1
Neplatná specifikace
jednotky 0 Zkopírovaný soubor(y)


Poznámka: pg_upgrade_utility.log umístěná v %AppData% bude odebrána po kliknutí na tlačítko OK, když se během dialogového okna upgradu zobrazí zpráva o neúspěšném upgradu. Proto musí být tento soubor shromážděn před kliknutím na OK a existující dialogové okno pro upgrade.

Poznámka: Databáze AppSync se nachází v jiném než výchozím umístění, na jednotce E: v tomto příkladu.

Causa

Spouštěč je problém související s oprávněním, jehož přesná příčina není známa.
Nástroj pro upgrade je spuštěn jako správce a uživatel, který je přihlášen při spuštění nástroje pro upgrade jako správce pomocí metody kliknutí pravým tlačítkem, je správce domény, který existuje v místní skupině správců a má plná práva k jednotce E:.

Bez ohledu na to, pokud k ladění použijete příkaz procmon, najdete chyby oprávnění pro přihlášeného uživatele k jednotce E:.

Resolução

Výslovně poskytnout plné oprávnění správce jednotky E: konkrétnímu uživateli, který je přihlášen při spuštění procesu upgradu.

Produtos afetados

AppSync

Produtos

AppSync
Propriedades do artigo
Número do artigo: 000057208
Tipo de artigo: Solution
Último modificado: 19 set. 2025
Versão:  6
Encontre as respostas de outros usuários da Dell para suas perguntas.
Serviços de suporte
Verifique se o dispositivo está coberto pelos serviços de suporte.