NetWorker: il backup di Oracle non viene eseguito e l'archivio protetto restituisce un errore durante il failover del server NetWorker
Resumo: Quando si verifica un failover del servizio cluster di NetWorker da un nodo all'altro, è impossibile eseguire il backup di Oracle e l'archivio protetto restituisce un errore ...
Este artigo aplica-se a
Este artigo não se aplica a
Este artigo não está vinculado a nenhum produto específico.
Nem todas as versões do produto estão identificadas neste artigo.
Sintomas
Nessuna modifica, tuttavia il valore *@* viene visualizzato nel campo Remote Access della risorsa client del server NetWorker
Il backup di Oracle non viene eseguito. È necessario eliminare o modificare la procedura guidata del client per l'opzione RMAN per ripristinare il funzionamento del backup sul nodo in cui si è verificato il failover
Durante il failover del servizio cluster di NetWorker, il backup di Oracle non viene eseguito restituendo il seguente errore:
Oracle_Client: Unable to obtain the user credentials from the lockbox due to the following error: 'Failed to open lockbox D:\nsr\lockbox\Oracle_Client\clb.lb'. Verificare che l'utente 'xyz' sull'host 'Oracle_Client' sia presente nell'attributo Users della risorsa archivio protetto.
Il backup di Oracle non viene eseguito. È necessario eliminare o modificare la procedura guidata del client per l'opzione RMAN per ripristinare il funzionamento del backup sul nodo in cui si è verificato il failover
Durante il failover del servizio cluster di NetWorker, il backup di Oracle non viene eseguito restituendo il seguente errore:
Oracle_Client: Unable to obtain the user credentials from the lockbox due to the following error: 'Failed to open lockbox D:\nsr\lockbox\Oracle_Client\clb.lb'. Verificare che l'utente 'xyz' sull'host 'Oracle_Client' sia presente nell'attributo Users della risorsa archivio protetto.
Causa
Il campo Remote Access della risorsa del server NetWorker (nome del cluster NetWorker) mostra il valore *@*.
Se il valore *@* viene visualizzato nell'elenco Remote access, in RAP DB non sarà presente alcuna informazione utile a NetWorker per stabilire qual è l'altro nodo e NetWorker non è in grado di autorizzare tutti gli host (anche se potesse, NetWorker non potrebbe farlo poiché rappresenterebbe una falla importante nella sicurezza). L'archivio protetto sul nodo attivo è stato probabilmente creato sul nodo attivo e il nodo passivo non è stato aggiunto all'elenco dei nodi consentiti (questo è ciò che significa l'errore The system hostname key is missing. È probabile che questo archivio protetto si apra senza problemi sull'altro nodo e avrà solo un nodo attivo nell'elenco.
Se il valore *@* viene visualizzato nell'elenco Remote access, in RAP DB non sarà presente alcuna informazione utile a NetWorker per stabilire qual è l'altro nodo e NetWorker non è in grado di autorizzare tutti gli host (anche se potesse, NetWorker non potrebbe farlo poiché rappresenterebbe una falla importante nella sicurezza). L'archivio protetto sul nodo attivo è stato probabilmente creato sul nodo attivo e il nodo passivo non è stato aggiunto all'elenco dei nodi consentiti (questo è ciò che significa l'errore The system hostname key is missing. È probabile che questo archivio protetto si apra senza problemi sull'altro nodo e avrà solo un nodo attivo nell'elenco.
Resolução
Applicato quanto segue al campo "Remote Access" della risorsa del server NetWorker (nome del cluster NetWorker):
*@Physical_Node1
*@Physical_Node2
Eseguire il backup e selezionare OK. Le informazioni dell'archivio protetto vengono aggiornate correttamente con le informazioni sul nodo fisico.
Non è necessario eliminare né modificare il client Oracle
*@Physical_Node1
*@Physical_Node2
Eseguire il backup e selezionare OK. Le informazioni dell'archivio protetto vengono aggiornate correttamente con le informazioni sul nodo fisico.
Non è necessario eliminare né modificare il client Oracle
Produtos afetados
NetWorkerProdutos
NetWorkerPropriedades do artigo
Número do artigo: 000067776
Tipo de artigo: Solution
Último modificado: 03 mai. 2024
Versão: 4
Encontre as respostas de outros usuários da Dell para suas perguntas.
Serviços de suporte
Verifique se o dispositivo está coberto pelos serviços de suporte.