NVP vProxy: Os backups de VM apresentam falha com a mensagem "no matching devices for save of client vCenter Name: check storage nodes, device, or pools"

Resumo: As máquinas virtuais protegidas pelo equipamento vProxy NVP apresentam falha no backup. O log de ação de backup declara "no matching devices for save of client vCenter Name: check storage nodes, device, or pools" ...

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Sintomas

  • O backup da máquina virtual falha logo após iniciar, com o seguinte erro registrado no log de ações do NetWorker Management Console:
DD/MM/YYYY HH:MM:SS Unable to process VM 'VM_NAME': no matching devices for save of client `VCENTER_NAME' check storage nodes, devices or pools
DD/MM/YYYY HH:MM:SS VM_NAME: Backup failed
Nota: Esse mesmo erro pode aparecer para outros tipos de backup (file system, banco de dados e assim por diante). As etapas neste artigo da KB podem ser usadas para solucionar esse problema.

Causa

Esse não é um problema do vProxy. A falha está ocorrendo durante a seleção do dispositivo. O fluxo de trabalho não consegue reconciliar um dispositivo utilizável. Há um problema de comunicação entre o servidor do NetWorker, o nó de armazenamento e o dispositivo existentes ou há um possível conflito de configuração.

Resolução

1. Faça log-in no NetWorker Management Console (NMC).
2. Vá para Protection-Policies> e selecione o fluxo de trabalho no menu esquerdo.
3. Anote o pool e o nó de armazenamento configurados na ação de backup do fluxo de trabalho:

Pool e nó de armazenamento definidos na ação de backup

4. Vá para Media-Media>Pools e abra as propriedades do pool usado pelo workflow.
5. Na guia Selection Criteria, anote todos os dispositivos com uma marca de seleção. Se houver algum dispositivo verificado, isso significa que o pool está restrito a usar apenas esses dispositivos. 

Critérios de seleção do pool

Nota: O dispositivo deve ser do tipo Data Domain. Para a proteção do VMware usando vários dispositivos em um só pool, cada dispositivo deve residir no mesmo host do Data Domain.

6. Vá para Devices-Devices> e confirme se os dispositivos selecionados nos critérios de seleção estão montados. Um dispositivo montado mostra um rótulo de volume. 

O dispositivo está montado

Nota: Se a coluna Volume Name estiver vazia, o dispositivo será desmontado. Clique com o botão direito do mouse no dispositivo e selecione Montar. Monitore a janela Log e alertas em caso de problemas na montagem do dispositivo.

7. Abra as propriedades do dispositivo e certifique-se de que a caixa "somente leitura" esteja desmarcada:

A caixa somente leitura do dispositivo está desmarcada

8. Vá para Media-DiskVolumes, certifique-se> de que o volume seja anexável.

O volume do disco é anexável

9. Vá para Devices-Storage>Nodes e confirme se o nó de armazenamento indicado na etapa 3 está no estado "ready":

O nó de armazenamento do NetWorker está pronto e habilitado

NOTA: nsrserverhost é o nó de armazenamento local do servidor do NetWorker. Todos os dispositivos mostrados com um prefixo rd= significam que eles são configurados por meio de um nó de armazenamento "remoto" do NetWorker. 

10. Vá para Protection-Clients> e abra as propriedades do client do recurso client do vCenter Server.
11. Na guia Globais (2 de 2), verifique se as entradas do nó de armazenamento existem para os nós de armazenamento usados durante os backups de VM desse vCenter. Vários nós de armazenamento podem ser listados, uma entrada por linha.

image.png

Nota: O modo View-Diagnostic> deve estar habilitado para ver as especificações dos nós de armazenamento nas propriedades do client.

Mais informações

Produtos afetados

NetWorker

Produtos

NetWorker Family
Propriedades do artigo
Número do artigo: 000200894
Tipo de artigo: Solution
Último modificado: 19 mar. 2025
Versão:  2
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