PowerStore:NVMeoFボリュームをマッピングすると、マルチアプライアンス クラスターでサービス停止が発生する可能性がある

Resumo: マルチアプライアンス クラスターにNVMeoFボリュームをマッピングすると、ボリュームが作成されているアプライアンスのサービスが停止する可能性があります。

Este artigo aplica-se a Este artigo não se aplica a Este artigo não está vinculado a nenhum produto específico. Nem todas as versões do produto estão identificadas neste artigo.

Sintomas

マルチアプライアンス クラスターにNVMeoFボリュームをマッピングすると、ボリュームが作成されているアプライアンスのサービスが停止する可能性があります。これは、appliance#2以降でのみ発生する可能性があります。これは、最初のアプライアンスでは発生しません。

 

環境:

  • マルチアプライアンス クラスター
  • ホストはNVMe/FCまたはNVMe/TCPを介して接続されます。
  • (a)アプライアンスの追加に障害が発生した、または(b)アプライアンスの削除が複数回実行された。

 

現象:

  • ノードが予期せず再起動することがあります。
  • 両方のノードが再起動すると、サービスが中断する可能性があります。

 

Causa

  • NVMeoF(NVMe/FCまたはNVMe/TCP)では、非対称ネームスペース アクセス(ANA)
    ANAをサポートする基本的なメカニズムが、ボリューム アクセス特性がNVMeコントローラー間で異なる可能性があるアプライアンスで発生します。
    :ノードAのボリューム1は最適化できますが、ノードBのボリューム1は最適化されていません。
  • この概念は、ターゲット ポート グループ(TPG)を使用したALUAと似ています。
    各ノードには、各ノードの状態(最適化済みと非最適化)を区別するために、一意のTPG IDが割り当てられます
  • PowerStoreでNVMe-oFを使用すると、各アプライアンスに複数のANAグループがあります。
    • ANAグループ#1 - アプライアンス間のボリューム移行に使用されます(グループIDはクラスター全体で1です)
    • ANAグループ #X - ノードAが最適化され、ノードBが最適化されていないボリュームを表すために使用されます
    • ANAグループ #Y - ノードAが非最適化で、ノードBが最適化されているボリュームを表すために使用されます。
    • ANAグループ #Z(今後使用):ノードAとノードBが最適化されているボリューム(アクティブ/アクティブ)を表すために使用されます。
  • アプライアンスを追加する場合、Control-Pathは特別なシーケンス番号を使用して、作成するターゲット ポート グループIDを決定します。
    このシーケンスは、追加されたアプライアンスに障害が発生した場合でも増加するだけです。追加したアプライアンスに複数回失敗すると、シーケンスが非常に大きくなる可能性があります。
  • ソフトウェアの問題により、ANAグループIDの最大数に制限がありますが、Control-Pathには制限がありません。
  • ボリュームをNVMeホストにマッピングすると、ボリュームは正しいANAグループに分類されます。ANAグループは、ボリュームを所有するノードのTPG IDから導出されます。
  • マッピング操作により、ソフトウェア モジュールに障害が発生し、ノードの再起動につながる可能性があります

 

Resolução

この問題は、PowerStoreOS 4.0.0で修正されています。

 

対策

  • グローバル サービスにエスカレーションしてサポートを受け、リカバリー後にPowerStoreOS 4.0.0へのアップグレードを計画します。迅速な対応については、このKB記事を参照してください。

 

Produtos afetados

PowerStore
Propriedades do artigo
Número do artigo: 000216639
Tipo de artigo: Solution
Último modificado: 28 mai. 2024
Versão:  3
Encontre as respostas de outros usuários da Dell para suas perguntas.
Serviços de suporte
Verifique se o dispositivo está coberto pelos serviços de suporte.