PowerStore: A verificação de integridade de um firmware de componente poderá falhar se a fonte de alimentação tiver sido substituída anteriormente
Resumo: A verificação de integridade de uma verificação de firmware de componente poderá falhar se uma fonte de alimentação tiver sido substituída no passado.
Sintomas
A verificação de integridade de um "Component Firmware Check" pode falhar e o firmware da fonte de alimentação no equipamento está marcado como "Upgrade needed".
| $ svc_health_check execução : Verificação de firmware de componente node_a firmware de componentes com falha precisa ser atualizado (KB#000201500) Verificação de firmware de componente node_b firmware de componentes com falha precisa ser atualizado (KB#000201500) |
Causa
Se houver um histórico de que uma fonte de alimentação (PS) em um equipamento tenha sido substituída no passado e o nó A não tenha sido reinicializado desde então, o firmware da PS não recebeu upgrade e poderá permanecer tão antigo quanto quando as peças de substituição tinham uma versão de firmware mais antiga do que o pacote de firmware no repositório com um PowerStoreOS em execução atualmente. Esta é uma especificação de projeto (FAD). As atualizações de firmware para fontes de alimentação (PSUs) só serão iniciadas se o BMC detectar firmware mais antigo durante a fase POST. Observe que, por padrão, o nó A é responsável por acionar atualizações para ambas as PSUs.
Resolução
Isso não afeta a operação normal imediatamente nessas condições, mas sugere-se que seja resolvido antes da operação de NDU, seguindo as etapas abaixo.
Para recuperar a condição uma vez, ela ocorreu
- Verifique se há um histórico de que as fontes de alimentação do equipamento foram substituídas no passado.
- Verifique se o nó A não foi reinicializado desde então.
- Se a condição acima for atendida, verifique se ambas as PSUs estão íntegras e fornecendo alimentação de entrada. Em seguida, execute uma reinicialização manual do nó A que inicia o upgrade de firmware do PS0 e/ou PS1.
Nota:
- Certifique-se de verificar se o status do nó B está ativo e íntegro antes de prosseguir com a reinicialização do nó A.
- Certifique-se de que todos os iniciadores do host estejam conectados corretamente aos dois nós.
4. Execute novamente a verificação de integridade para ver se a verificação de firmware do componente será aprovada.
Se, depois de seguir as instruções deste artigo, o problema persistir, entre em contato com o suporte técnico da Dell para obter assistência.
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