O provisionamento do PowerScale SupportAssist trava na ENTRADA
Resumo: Um problema em que você começa a provisionar o SupportAssist no PowerScale OneFS e verifica "# isi supportassist provision view" e parece que ele está travado no INCOMING.
Sintomas
Ao ativar o SupportAssist, analise a KB PowerScale: Não é possível provisionar o código 9.5x e posterior do Dell SupportAssist OneFS para obter mais informações.
# isi supportassist provision start --access-key=<key> --pin=<pin>
# isi supportassist provision view
Provision Status:
Current State: INCOMING
Sub-state: INCOMING
Success or Fail: -
Percent Complete: -
Error: -
E parece que para de responder nesse status.
Causa
Verifique em /var/log/isi_crispies_d.log para erros semelhantes a:
2024-10-04T11:28:34.667359-04:00 <3.3> powerscale-1(id10) isi_crispies_d[2406]: MainThread(isi_crispies_d:387) ERROR: Exception(main):400 Client Error: Bad Request for url: https://localhost:9443/ese/security/certificate/webserver
2024-10-04T11:23:58.143464-04:00 <3.7> powerscale-1(id10) isi_crispies_d[2406]: MainThread(ese_request.py:132) DEBUG: Response[400 /ese/security/certificate/webserver] Body: {"status_Code": 400, "message": "Provided certificate has expired."}
Resolução
Um problema em que um cluster em um fuso horário não GMT leva a um vencimento falso de um certificado. Esperar várias horas (de preferência durante a noite), quando o tempo que está procurando é atingido, ele provisiona automaticamente.
Se passarem 24 horas e ele ainda estiver preso no INCOMING, inicie uma nova coleta de conjunto de logs e abra um chamado com o suporte da Dell Technologies para análise.
Versões afetadas do OneFS: 9.7.1.0 e posterior, 9.5.1.1 e posteriores
O problema foi resolvido no OneFS 9.8.x.x e versões posteriores.