Várias falhas de produtos Dell devido à configuração de "gerenciamento em banda" do BIOS que desativa a IPMI

Resumo: Vários produtos Dell Enterprise se comportam inesperadamente se a IPMI é intencionalmente desativada na comunicação entre o sistema operacional e o iDRAC. Isso pode ser feito desativando a configuração "In-band Management Interface" nas configurações de segurança do sistema BIOS. ...

Este artigo aplica-se a Este artigo não se aplica a Este artigo não está vinculado a nenhum produto específico. Nem todas as versões do produto estão identificadas neste artigo.

Sintomas

Vários produtos de software empresarial da Dell dependem da comunicação entre o iDRAC e o driver IPMI do sistema operacional. Estes são produtos populares da Dell, mas esta não é uma lista completa:

  • Pacotes de atualização Dell (DUP): Requer que o IPMI passe payloads de firmware para o iDRAC para que o iDRAC seja aplicado na reinicialização
  • OMSA (Dell OpenManage Server Administrator): Requer IPMI para a maioria dos monitoramento de componentes gerenciados pelo iDRAC, como ventiladores, energia etc.
  • Ferramentas do iDRAC: Racadm e ipmitool exigem IPMI para comunicação local do iDRAC
  • iDRAC Service Module (iSM): Exige que a IPMI estabeleça comunicações confiáveis de alta velocidade com o iDRAC por meio do dispositivo de rede USB criado
  • Atualização do sistema Dell (DSU): O coletor de inventário subjacente do DSU depende do IPMI para detectar determinados componentes e versões de firmware e deve aplicar o DUP aplicável
Quando a IPMI está desativada no Windows, geralmente um evento de advertência é registrado no registro de eventos do sistema Windows. Quando a IPMI está desativada no Linux, o seguinte erro é exibido:
Could not open device at /dev/ipmi0 or /dev/ipmi/0 or /dev/ipmidev/0 

Causa

Um possível motivo para a falha da IPMI fazer com que o produto Dell também falhe é a desativação intencional das configurações da "Interface de gerenciamento em banda" encontradas nas configurações do BIOS em "Segurança do sistema". Isso oculta completamente o barramento IPMI para o iDRAC do sistema operacional.

Outro motivo pode ser que o driver IPMI foi desativado no Windows ou que o módulo IPMI no Linux foi interrompido.

Resolução

O driver IPMI nativo do Windows deve ser ativado e carregado. Isso pode ser confirmado:

  1. Abra o Gerenciador de dispositivos e selecione Exibir > mostrar dispositivos ocultos
  2. Na seção Dispositivos do sistema , abra Dispositivo compatível com IPMI genérico da Microsoft
  3. Verifique se o status do dispositivo não tem erros

No Linux, verifique se os módulos IPMI estão ativos e carregados com "lsmod | grep -i ipmi", especialmente o módulo ipmi_si.

Verifique também, nas configurações do BIOS, se a interface de gerenciamento em banda de segurança > do sistema está ativada

Produtos afetados

Dell System Update, OpenManage Server Administrator, Update Packages, iDRAC Service Module
Propriedades do artigo
Número do artigo: 000247770
Tipo de artigo: Solution
Último modificado: 10 jul. 2025
Versão:  2
Encontre as respostas de outros usuários da Dell para suas perguntas.
Serviços de suporte
Verifique se o dispositivo está coberto pelos serviços de suporte.