NetWorker: Kopia zapasowa systemu Windows kończy się niepowodzeniem z poleceniem "VSS OTHER: sow_create_sysset_snapshot: VSS failed to process snapshot, error=0x0"

Сводка: Klient Windows NetWorker ulegnie awarii podczas tworzenia kopii zapasowej, co oznacza, że nie udało się utworzyć migawki USŁUGI VSS.

Данная статья применяется к Данная статья не применяется к Эта статья не привязана к какому-либо конкретному продукту. В этой статье указаны не все версии продуктов.

Симптомы

Podczas tworzenia kopii zapasowej NetWorker klienta Microsoft Windows krytyczne dyski wymagające korzystania z usługi kopiowania woluminów w tle (VSS) kopia zapasowa kończy się niepowodzeniem z następującym komunikatem: 
174424:save: Step (3 of 5) for PID-8568: Creating the snapshot for the selected save sets.
03/11/19 15:40:02.614837 UTF8 string for BCDPath is C:\Program Files\EMC NetWorker\nsr\tmp\xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxx\backcomp.xml
VSS OTHER: ERROR: VSS failed to process snapshot: 
03/11/19 15:40:02.630861 VSS OTHER: sow_create_sysset_snapshot: VSS failed to process snapshot, error=0x0
90108:save: Unable to save the SYSTEM STATE save sets: cannot create the snapshot.
03/11/19 15:40:02.630861 WriteTracker: nsrwriter_stop(8568:5204) -->.
03/11/19 15:40:02.630861 WriteTracker: nsrwriter_stop(8568:5204) error: NULL hProcess detected..
03/11/19 15:40:02.630861 WriteTracker: nsrwriter_stop(8568:5204) releasing hWriterMutex ....
03/11/19 15:40:02.630861 save workflow released nsrwriter lock.
03/11/19 15:40:02.630861 WriteTracker: nsrwriter_stop(8568:5204) <-- FALSE.
03/11/19 15:40:02.646091 WINDOWS ROLES AND FEATURES: sow_free_save called
03/11/19 15:40:02.646091 VSS USER DATA: sow_free_save called
03/11/19 15:40:02.646091 VSS OTHER: sow_free_save called
174918:save: Step (3 of 5) for PID-8568: Unable to complete the backup. See the savegrp log to track the closure steps of the backup.
175023:save: Unable to back up the save set 'pseudo_saveset'.

Причина

Jest to problem z systemem operacyjnym, który uniemożliwia tworzenie migawki.

Разрешение

Sprawdź stan zapisu systemu operacyjnego:

1. Otwórz wiersz polecenia (cmd) jako administrator.
2. Uruchom narzędzie diskShadow , uruchamiając następujące polecenie:
dyskshadow

3. Narzędzie disk shadow inicjuje, a w wierszu polecenia wyświetlany jest diskshadow>.
4. Wyświetl listę składników zapisujących system, uruchamiając następujące polecenie:
wyszczególnione moduły zapisujące listę 

5. Dane wyjściowe są długie, dlatego może być konieczne zwiększenie buforu wiersza polecenia w celu przechwycenia wszystkich danych.
6. Aby zachować zapisane dane, użytkownik powinien skopiować dane wyjściowe do pliku tekstowego. Uruchom następujące polecenie, aby zarejestrować wszystkie uruchomione w narzędziu diskshadow. W tym przypadku potrzebne są tylko szczegółowe dane wyjściowe list writers:
diskShadow /l "PATH_TO_OUTPUT_FILE"
Przykład:
diskshadow /l "C:\Windows\Temp\listoutput.txt"

7. Wyszukaj w pliku ciąg "[Nie istnieje]"
Przykład:
- Volumes affected by this component:
- \\?\Volume{9710a803-0000-0000-0000-501f00000000}\ [C:\]
- \\?\Volume{294e539b-7658-40d0-8751-e826e6d8813f}\ [D:\]
- \\HOSTNAME\SHARENAME\ [Does not exist]
UWAGA: Żadna ścieżka UNC w tym miejscu (począwszy od \\nazwa_hosta\sharename — gdzie jest to host w sieci) nie jest obsługiwana przez migawkę VSS.  Spójrz na powyższą sekcję w danych wyjściowych, która powinna zawierać wadliwy element i odpowiedzialny za plik binarny.

Przykład:
+ Component "System Writer:\Win32 Services Files"
<snip>
- File List: Path = \\hostname\sharename\path\bin, Filespec = scd.exe
- Paths affected by this component:
<snip>
 - \\hostname\sharename\path\bin
Nie jest to problem networker, ale problem z systemem operacyjnym. Jest to zazwyczaj spowodowane przez aplikację zainstalowaną w systemie lub nieudaną instalację. 
Jeśli kopia zapasowa NetWorker działała wcześniej, a następnie zatrzymana, po stronie systemu operacyjnego należy wykonać głębszą analizę. Dziennik zdarzeń systemu Windows w podglądzie zdarzeń powinien zawierać więcej szczegółów, jeśli zostały przefiltrowane do tego dnia, kiedy błąd wystąpił po raz pierwszy. Pomoc techniczna firmy Microsoft jest zalecana w przypadku wszelkich stałych problemów z usługą VSS.

Дополнительная информация

Затронутые продукты

NetWorker

Продукты

NetWorker
Свойства статьи
Номер статьи: 000055493
Тип статьи: Solution
Последнее изменение: 27 Sep 2023
Версия:  3
Получите ответы на свои вопросы от других пользователей Dell
Услуги технической поддержки
Проверьте, распространяются ли на ваше устройство услуги технической поддержки.