SyncIQ fails with error: Maximum file name length support differs

Zhrnutie: A SyncIQ job fails when Long Filename (LFN) support is enabled on a source or target cluster while not enabled on the peer cluster.

Tento článok sa vzťahuje na Tento článok sa nevzťahuje na Tento článok nie je viazaný na žiadny konkrétny produkt. V tomto článku nie sú uvedené všetky verzie produktov.

Symptómy

SyncIQ fails with error: "Maximum file name length support differs between the source and target. Cannot sync a cluster with long file names to a target cluster without long name support enabled"

Príčina

A SyncIQ job fails if LFN is enabled on only one cluster, source, or target, in a SyncIQ relationship.
On OneFS, the default name length defaults are 255 Bytes in length and 255 characters. Both clusters in a SyncIQ relationship must be able to support Long Filenames (LFN) that exceed the default maximum.

Riešenie

Check whether LFN is enabled on both source and target clusters:

NOTE: If enabled, it is not reversible.

 

# isi_for_array -s 'sysctl efs.bam.long_file_name_enabled'

Check the LFN setting for SyncIQ's source and target paths:

# isi sync policies view <policy_name> |grep Path:
# isi namelength list

Enable LFN on the cluster:

NOTE: If enabled, it is not reversible.
 
# isi_sysctl_cluster efs.bam.long_file_name_enabled=1 --explanation="Enable LFN"

 

NOTE: Sometimes, a matching name length setting might also be required to mirror the source setting.


Example command:

 

# isi namelength create --max-bytes xxxx --max-chars xxxx /ifs/<lfn_path>

Ďalšie informácie

LFN was introduced in OneFS 9.3.
More information: http://www.unstructureddatatips.com/onefs-and-long-filenames/This hyperlink is taking you to a website outside of Dell Technologies.

Dotknuté produkty

Isilon SyncIQ

Produkty

PowerScale
Vlastnosti článku
Číslo článku: 000343370
Typ článku: Solution
Dátum poslednej úpravy: 12 nov 2025
Verzia:  2
Nájdite odpovede na svoje otázky od ostatných používateľov spoločnosti Dell
Služby podpory
Skontrolujte, či sa na vaše zariadenie vzťahujú služby podpory.