NetWorker NVP vProxy: Сбой резервного копирования ВМ с ошибкой «Err: 5037 -Cannot resolve IP address from Host DD_HOSTNAME_FAILOVER»

摘要: Сбой резервного копирования ВМ VMware с ошибкой Err: 5037 -Cannot resolve IP address from Host DD_HOSTNAME_FAILOVER

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

Интеграция NetWorker VMware Protection настраивается с помощью устройства vProxy.  При резервном копировании на уровне образов виртуальной машины (ВМ) не удается открыть сессию на целевом устройстве Data Domain.  В журнале сеанса резервного копирования отображается следующее.

YYYY/MM/DD HH:MM:SS ERROR:  [NW_BUILD] UUID:VM_MOREF:VM_NAME: ddp_connect_with_config() failed, Hostname: DD_HOSTNAME, Err: 5037-Cannot resolve IP address from Host DD_HOSTNAME_FAILOVER for ip family 0
YYYY/MM/DD HH:MM:SS ERROR:  [NW_BUILD] UUID:VM_MOREF:VM_NAME: Unable to open session to target device "DD_HOSTNAME".

原因

Этот признак может быть вызван следующим:
  • Целевая система Data Domain не может разрешимый DNS.
  • Требуемые порты заблокированы между vProxy и Data Domain.

解决方案

Выполните следующие действия:
  1. Войдите в vProxy через SSH (admin) и проверьте, является ли Data Domain разрешимым DNS. FQDN, имя и IP-адрес должны отвечать правильно: 
    1. nslookup DataDomain_FQDN
    2. nslookup DataDomain_ShortName
    3. nslookup DataDomain_IPaddress
  1. Если Data Domain не разрешим по DNS и/или ошибка также отображается DD_HOSTNAME_FAILOVER добавьте запись файла /etc/hosts в vProxy для Data Domain:
Примечание. Имя должно соответствовать синтаксису ресурса Data Domain, настроенного в NetWorker. Псевдоним переключения при отказе можно добавить к той же строке, например:
10.0.0.10           DataDomain01.domain.com       DataDomain01      DataDomain01-failover.domain.com
  1. Убедитесь, что vProxy может связаться с Data Domain на следующих портах, утвердив все порты, которые не отвечают на запросы: 22, 111, 131, 161, 2049, 2052
curl -v DataDomain_FQDN:Port_Number

受影响的产品

NetWorker

产品

NetWorker
文章属性
文章编号: 000173645
文章类型: Solution
上次修改时间: 15 8月 2025
版本:  4
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。