Avamar: Il backup SQL ha esito negativo con l'errore: "È stato identificato un divario di log o non è stato trovato un backup completo"
摘要: Avamar: Il backup SQL ha esito negativo con l'errore: "È stato identificato un divario di log o non è stato trovato un backup completo."
本文适用于
本文不适用于
本文并非针对某种特定的产品。
本文并非包含所有产品版本。
症状
Il backup SQL non riesce in modo casuale con un errore di gap del log: "È stato identificato un divario di log o non è stato trovato un backup completo."
La parte corrispondente dal registro di backup (con debug):
La parte corrispondente dal registro di backup (con debug):
2022/05/04-23:00:22.09299 [avsql_assist] called avspawnpipe::~avspawnpipe
2022/05/04-23:00:22.09299 [avsql_assist] avspawnpipe::~avspawnpipe done with avspawnpipe::wait stdout
2022/05/04-23:00:22.09299 [avsql_assist] called avspawnpipe::~avspawnpipe
2022/05/04-23:00:22.09299 [avsql_assist] avspawnpipe::~avspawnpipe done with avspawnpipe::wait stderr
2022/05/04-23:00:22.16199 [avsql_assist] xml_message::parse parse error: expected = at 000000001C8D3041 in input
2022/05/04-23:00:22.17100 [avsql_assist] ERROR: xml_message::validname('') invalid xml name
2022/05/04-23:00:22.17100 [avsql_assist] avsql_metadata::avsql_metadata sqlmetadata = '< />
'..
.
.
.
2022/05/04-23:00:22.18400 [avsql_assist] ===> avsql_assist::evaluate_backup_lsn
2022-05-04 19:00:22 avsql Warning : Evaluate backup LSN numbers is not supported in this version of metadata file (v0.000000).
2022/05/04-23:00:22.18499 [avsql_assist] sqlconnectimpl_smo::get_last_backup_lsn
2022/05/04-23:00:22.18499 [avsql_assist] retrieving last backup lsn for '' db from sys.database_recovery_status
2022/05/04-23:00:22.18499 [avsql_assist] ===> sqlconnectimpl_smo::InitDll
2022/05/04-23:00:22.18499 [avsql_assist] SMO dll already loaded.
2022/05/04-23:00:22.18600 [avsql_assist] SMOWrap::SMO_GetLastBackupLSN
2022/05/04-23:00:22.19000 [avsql_assist] database '', last backup lsn = '271000002085600001'
2022/05/04-23:00:22.19099 [avsql_assist] avsql_metadata::get
2022/05/04-23:00:22.19099 [avsql_assist] ===> avsql_metadata::get
2022/05/04-23:00:22.19099 [avsql_assist] avsql_assist::align_numeric_ustrings
2022/05/04-23:00:22.19099 [avsql_assist] Before alignment - Str1: '', Str2: '271000002085600001'
2022/05/04-23:00:22.19099 [avsql_assist] After alignment - Str1: '000000000000000000', Str2: '271000002085600001'
2022/05/04-23:00:22.19099 [avsql_assist] : A log gap was identified or a full backup was not found.
原因
Il problema è l'analisi del file sqlmeta dal backup incrementale precedente.
La parte inferiore del file sqlmeta (presente nei file dell'area system_info). Consultare l'articolo della KB 000102778 Avamar - Come recuperare i file dell'area system_info da un backup Avamar
FILE TRONCATO DA 17411017 A BYTE 16777216 ****
Il file sqlmeta è stato troncato a causa della limitazione delle dimensioni di avtar di 16 MB.
SQL Server in questione dispone di più database. Ogni database dispone di più gruppi di file, il che ha causato un file (sqlmeta) ad avere più di 90.000 righe (dimensioni di oltre 16 MB).
La parte inferiore del file sqlmeta (presente nei file dell'area system_info). Consultare l'articolo della KB 000102778 Avamar - Come recuperare i file dell'area system_info da un backup Avamar
FILE TRONCATO DA 17411017 A BYTE 16777216 ****
Il file sqlmeta è stato troncato a causa della limitazione delle dimensioni di avtar di 16 MB.
SQL Server in questione dispone di più database. Ogni database dispone di più gruppi di file, il che ha causato un file (sqlmeta) ad avere più di 90.000 righe (dimensioni di oltre 16 MB).
解决方案
Per risolvere il problema di Avamar: Il backup SQL ha esito negativo con l'errore: "È stato identificato un divario di log o non è stato trovato un backup completo."
- Aggiornare Avamar Server alla seguente software release.
- 19.8.100-83
- Al termine dell'aggiornamento, applicare HF 338735
- Seguire questo articolo della Knowledge Base per scaricare l'HF e ricordare di leggere le istruzioni del file README prima di applicarlo:
受影响的产品
Avamar文章属性
文章编号: 000201975
文章类型: Solution
上次修改时间: 15 2月 2024
版本: 4
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。