Avamar: O backup do SQL está falhando com o erro: "Uma lacuna de registro foi identificada ou um backup completo não foi encontrado"
摘要: Avamar: O backup do SQL está falhando com o erro: "Foi identificada uma lacuna de registro ou um backup completo não foi encontrado."
本文适用于
本文不适用于
本文并非针对某种特定的产品。
本文并非包含所有产品版本。
症状
O backup do SQL está falhando aleatoriamente com um erro de lacuna de registro: "Foi identificada uma lacuna de registro ou um backup completo não foi encontrado."
A parte correspondente do registro de backup (com depuração):
A parte correspondente do registro de backup (com depuração):
2022/05/04-23:00:22.09299 [avsql_assist] called avspawnpipe::~avspawnpipe
2022/05/04-23:00:22.09299 [avsql_assist] avspawnpipe::~avspawnpipe done with avspawnpipe::wait stdout
2022/05/04-23:00:22.09299 [avsql_assist] called avspawnpipe::~avspawnpipe
2022/05/04-23:00:22.09299 [avsql_assist] avspawnpipe::~avspawnpipe done with avspawnpipe::wait stderr
2022/05/04-23:00:22.16199 [avsql_assist] xml_message::parse parse error: expected = at 000000001C8D3041 in input
2022/05/04-23:00:22.17100 [avsql_assist] ERROR: xml_message::validname('') invalid xml name
2022/05/04-23:00:22.17100 [avsql_assist] avsql_metadata::avsql_metadata sqlmetadata = '< />
'..
.
.
.
2022/05/04-23:00:22.18400 [avsql_assist] ===> avsql_assist::evaluate_backup_lsn
2022-05-04 19:00:22 avsql Warning : Evaluate backup LSN numbers is not supported in this version of metadata file (v0.000000).
2022/05/04-23:00:22.18499 [avsql_assist] sqlconnectimpl_smo::get_last_backup_lsn
2022/05/04-23:00:22.18499 [avsql_assist] retrieving last backup lsn for '' db from sys.database_recovery_status
2022/05/04-23:00:22.18499 [avsql_assist] ===> sqlconnectimpl_smo::InitDll
2022/05/04-23:00:22.18499 [avsql_assist] SMO dll already loaded.
2022/05/04-23:00:22.18600 [avsql_assist] SMOWrap::SMO_GetLastBackupLSN
2022/05/04-23:00:22.19000 [avsql_assist] database '', last backup lsn = '271000002085600001'
2022/05/04-23:00:22.19099 [avsql_assist] avsql_metadata::get
2022/05/04-23:00:22.19099 [avsql_assist] ===> avsql_metadata::get
2022/05/04-23:00:22.19099 [avsql_assist] avsql_assist::align_numeric_ustrings
2022/05/04-23:00:22.19099 [avsql_assist] Before alignment - Str1: '', Str2: '271000002085600001'
2022/05/04-23:00:22.19099 [avsql_assist] After alignment - Str1: '000000000000000000', Str2: '271000002085600001'
2022/05/04-23:00:22.19099 [avsql_assist] : A log gap was identified or a full backup was not found.
原因
O problema é analisar o arquivo sqlmeta do backup incremental anterior.
A parte inferior do arquivo sqlmeta (existe em arquivos de área system_info - consulte KB 000102778 Avamar - Como recuperar os arquivos de área system_info de um backup do Avamar
ARQUIVO TRUNCADO DE 17411017 ATÉ 16777216 BYTES ******
O arquivo sqlmeta foi truncado devido à limitação de tamanho avtar de 16 MB.
O SQL Server em questão tem vários bancos de dados. Cada banco de dados tem vários grupos de arquivos, o que fez com que um arquivo (sqlmeta) tenha mais de 90 mil linhas (tamanho de mais de 16 MB).
A parte inferior do arquivo sqlmeta (existe em arquivos de área system_info - consulte KB 000102778 Avamar - Como recuperar os arquivos de área system_info de um backup do Avamar
ARQUIVO TRUNCADO DE 17411017 ATÉ 16777216 BYTES ******
O arquivo sqlmeta foi truncado devido à limitação de tamanho avtar de 16 MB.
O SQL Server em questão tem vários bancos de dados. Cada banco de dados tem vários grupos de arquivos, o que fez com que um arquivo (sqlmeta) tenha mais de 90 mil linhas (tamanho de mais de 16 MB).
解决方案
Para resolver o Avamar: O backup do SQL está falhando com o erro: "Foi identificada uma lacuna de registro ou um backup completo não foi encontrado."
- Faça upgrade do servidor Avamar para a versão de software a seguir.
- 19.8.100-83
- Depois que o upgrade for concluído, aplique o HF 338735
- Siga este artigo da base de conhecimento para fazer download do HF e lembre-se de ler as instruções do arquivo LEIA-ME antes de aplicar:
受影响的产品
Avamar文章属性
文章编号: 000201975
文章类型: Solution
上次修改时间: 15 2月 2024
版本: 4
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。