Невозможно привязать LDAPs в Dell Security Management Server Virtual 11.0 или более поздней версии

摘要: В этой статье описывается ситуация, когда dell Security Management Server Virtual v11.0 и более поздних версий получает сообщение об ошибке «unable to connect to the server» при привязке LDAP в консоли удаленного управления. ...

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

Затронутые продукты:

  • Dell Security Management Server Virtual

Затронутые версии:

  • Версия 11.0 и более поздние

Затронутые операционные системы:

  • Linux

Обычно наблюдается после модернизации до Dell Security Management Server Virtual v11.0 или более поздней версии и попытки использовать те же параметры LDAPs, которые работали нормально до обновления, теперь показывают плохое состояние домена и при попытке сохранения параметров LDAPs возникают ошибки.

При попытке привязки LDAP в консоли удаленного управления отображается ошибка «unable to connect to the server». В журналах отображаются ошибки подтверждения SSL:

org.springframework.ldap.CommunicationException: simple bind failed: ADSERVER.DOMAIN.COM:636; nested exception is javax.naming.CommunicationException: simple bind failed: ADSERVER.DOMAIN.COM:636 [Root exception is javax.net.ssl.SSLHandshakeException: No subject alternative DNS name matching ADSERVER.DOMAIN.COM found.]

Не удается подключиться к серверу
Рис. 1. (только на английском языке) Не удается подключиться к серверу

原因

Самопроверка сертификатов и обновлений Java в версии 11.0. Алгоритмы идентификации конечных точек включены по умолчанию для повышения надежности соединений LDAPS (безопасный протокол LDAP через TLS). Из журнала изменений: https://www.oracle.com/technetwork/java/javase/8u181-relnotes-4479407.html Эта гиперссылка позволяет перейти на сайт за пределами Dell Technologies.

解决方案

Отключите идентификацию конечной точки, изменяя wrapper.conf, следуя приведенным ниже инструкциям.

Примечание.: При необходимости эту операцию можно выполнить по сеансу SSH. Как включить протокол SSH: Как включить SSH в Dell Security Management Server Virtual / Dell Data Protection Virtual Edition
  1. Остановите службы со ссылкой Как остановить и запустить службы в Dell Security Management Server Virtual / Dell Data Protection Virtual Edition.
  2. В главном меню выберите Launch Shell:

Выберите «Launch Shell»
Рис. 2. (Только на английском языке) Выберите «Launch Shell»

  1. Введите su dellsupport и нажмите клавишу Enter:

Введите su dellsupport
Рис. 3. (только на английском языке) Тип su dellsupport

  1. Введите пароль для dellsupport и нажмите клавишу Enter:

Введите пароль
Рис. 4. (Только на английском языке) Ввод пароля

  1. Введите sudo nano /opt/dell/server/security-server/conf/wrapper.conf.

Введите sudo nano /opt/dell/server/security-server/conf/wrapper.conf.
Рис. 5. (только на английском языке) Тип sudo nano /opt/dell/server/security-server/conf/wrapper.conf

  1. В разделе # Additional java parameters to the VM добавьте строку wrapper.java.additional.XX=-Dcom.sun.jndi.ldap.object.disableEndpointIdentification=true где XX инкрементно отображается в списке (в данном примере их 12):

Добавьте строку wrapper.java.additional.XX=-Dcom.sun.jndi.ldap.object.disableEndpointIdentification=true
Рис. 6. (только на английском языке) Добавить строку wrapper.java.additional.XX=-Dcom.sun.jndi.ldap.object.disableEndpointIdentification=true

  1. Нажмите CTRL + O, чтобы сохранить изменения.
  2. Нажмите CTRL + X, чтобы выйти.
  3. Введите exit и нажмите клавишу Enter , чтобы вывести из системы. dellsupport.

Введите exit.
Рис. 7. (только на английском языке) Тип exit

  1. Введите exit а затем нажмите клавишу Enter , чтобы вывести из оболочки главное меню.

Введите exit.
Рис. 8. (только на английском языке) Тип exit

  1. Запустите службы со ссылкой Как остановить и запустить службы в Dell Security Management Server Virtual / Dell Data Protection Virtual Edition.

Теперь можно выполнить привязку домена с помощью порта LDAPs.

受影响的产品

Dell Encryption
文章属性
文章编号: 000205453
文章类型: Solution
上次修改时间: 15 11月 2023
版本:  2
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。