NetWorker: Sanal Makine FLR'si "Dizin içeriği alınamadı..." hatasıyla sürekli olarak başarısız oluyor.

摘要: Windows Sanal Makinesi için Dosya Düzeyinde Kurtarma (FLR) işlemi sürekli olarak başarısız oluyor. FLR bağlantısı başarılıdır ancak göz atma işlemi "Could not get the directory content unable to get file list from VM (path) Access denied" mesajıyla başarısız olur. ...

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

/opt/emc/vproxy/runtime/logs/vflrd/mount-e28###a6-2##2-4##e-b##8-b900####2bd7.log günlüğünden:

YYYY-MM-DDTHH:MM:SSZ INFO: [29] ====End of output from agent mount. 
YYYY-MM-DDTHH:MM:SSZ INFO: [29] Successfully mounted VMDKs onto VM 'my_vmname' (vm-####) filesystem hierarchy at 'C:\Program Files (x86)\EMC\vProxy FLR Agent\flr\mountpoints\FLR65####027'. 
YYYY-MM-DDTHH:MM:SSZ INFO: [29] End of mount request processing; mountpoint is 'C:\Program Files (x86)\EMC\vProxy FLR Agent\flr\mountpoints\FLR65####027' (no error) 
YYYY-MM-DDTHH:MM:SSZ INFO: [29] Disconnected from session on vCenter 'myvcenter.com'. 
YYYY-MM-DDTHH:MM:SSZ INFO: [29] Adding FlrBrowseSessions session 'cb###4c0-7##0-4##9-b##1-711#####a983'

 

/opt/emc/vproxy/runtime/logs/vflrd/browse-cb0###c0-7##0-4##9-b##1-7116#####983.log günlüğünden:

YYYY-MM-DDTHH:MM:SSZ ERROR: [29] FLR:browse_files: Unable to perform FLR Agent operation 'browse_files' on VM IP Address: ##.##.##.## (vm-####). 
YYYY-MM-DDTHH:MM:SSZ ERROR: [29] Unable to retrieve file list from ##.##.##.## (vm-####) path 'F:\DFS-SHARE\Administration\MY_FOLDER' offset 0. 
YYYY-MM-DDTHH:MM:SSZ ERROR: [29] Could not get directory contents: Unable to retrieve file list from ##.##.##.## (vm-####) path '#:\DFS-SHARE\Administration\MY_FOLDER' offset 0. Unable to perform FLR Agent operation 'browse_files' on VM ##.##.##.## (vm-####). Cannot stat 'C:\Program Files (x86)\EMC\vProxy FLR Agent\flr\mountpoints\FLR65####027\02-#$\DFS-SHARE\Administration\MY_FOLDER': CreateFile C:\Program Files (x86)\EMC\vProxy FLR Agent\flr\mountpoints\FLR65####027\02-F$\DFS-SHARE\Administration\EXE_ADMIN: Access is denied. 
YYYY-MM-DDTHH:MM:SSZ ERROR: [29] FLR:browse_files: Cannot stat 'C:\Program Files (x86)\EMC\vProxy FLR Agent\flr\mountpoints\FLR65####027\02-#$\DFS-SHARE\Administration\MY_FOLDER': CreateFile C:\Program Files (x86)\EMC\vProxy FLR Agent\flr\mountpoints\FLR65####027\02-#$\DFS-SHARE\Administration\MY_FOLDER: Access is denied.

 

原因

  • Yukarıdaki belirtilerle FLR için başarısız olan VM'ler, Microsoft Dağıtılmış Dosya Sistemi'ni (DFS) kullanıyordur.
  • Microsoft DFS, kullanıcıların fiziksel olarak bir ağa dağıtılan paylaşılan dizinlerden oluşan bir ad alanı oluşturmasına olanak tanıyan bir Windows dosya sistemi özelliğidir. DFS ile kullanıcılar, çeşitli konumlarda bulunan dosyalara merkezi erişim sağlamak için bir grup dağıtılmış dizini seçtikleri herhangi bir şemaya göre mantıksal olarak düzenleyebilir.
  • Microsoft DFS hakkında daha fazla bilgi edinmek için DFS Ad Alanlarına genel bakış Microsoft makalesine bakın. Bu köprü bağlantı sizi Dell Technologies dışındaki bir web sitesine yönlendirir.

 

解决方案

  • NetWorker NVP vProxy - Sanal Makine Dosya Düzeyinde Kurtarma (FLR), Windows Dağıtılmış Dosya Sistemi'ni (DFS) desteklemez.
  • Dell Mühendislik ekibi, vProxy FLR'nin Microsoft Dağıtılmış Dosya Sistemi'ni (DFS) desteklemediğini tespit etti
  • Bu sınırlamanın ele alınması için 19.8 ve 19.9 sürümleri için NetWorker VMware Entegrasyon Rehberinin gelecek bir sürümünde kullanıma sunulması planlanmaktadır.

 

Geçici Çözüm:

  1. NetWorker Management Console (NMC) kullanıcı arayüzünden Dosya Düzeyinde Kurtarma (FLR) başlatma
  2. NetWorker Management Console (NMC) kullanıcı arayüzü kurtarmasında bağlama dosyası düzeyinde kurtarma (FLR) Sayfa başlığı: Dosya düzeyinde kurtarma için kaydetme kümesini bağlama
  3. NetWorker Management Console (NMC) kullanıcı arayüzünde Dosya Düzeyinde Kurtarma (FLR) Bağlama Noktasını bağlı durumda bırakın.
  4. Dizin içeriğini kopyalayıp Dağıtılmış Dosya Sistemi (DFS) Hedef Sanal Makinesine (VM) yapıştırmak için Windows Gezgini'ni kullanın.

 

文章属性
文章编号: 000217445
文章类型: Solution
上次修改时间: 16 10月 2024
版本:  4
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。