NetWorker: Віртуальна машина FLR постійно зазнає невдачі з повідомленням «Не вдалося отримати вміст каталогу...»

摘要: Відновлення на рівні файлів (FLR) для віртуальної машини Windows постійно зазнає невдачі. Монтування FLR виконано успішно, але перегляд не вдається для 3-4 тек із повідомленням «Не вдалося отримати вміст каталогу не вдалося отримати список файлів із віртуальної машини (шлях) Доступ заборонено». ...

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

З журналу /opt/emc/vproxy/runtime/logs/vflrd/mount-e28###a6-2##2-4##e-b##8-b900####2bd7.log:

YYYY-MM-DDTHH:MM:SSZ INFO: [29] ====End of output from agent mount. 
YYYY-MM-DDTHH:MM:SSZ INFO: [29] Successfully mounted VMDKs onto VM 'my_vmname' (vm-####) filesystem hierarchy at 'C:\Program Files (x86)\EMC\vProxy FLR Agent\flr\mountpoints\FLR65####027'. 
YYYY-MM-DDTHH:MM:SSZ INFO: [29] End of mount request processing; mountpoint is 'C:\Program Files (x86)\EMC\vProxy FLR Agent\flr\mountpoints\FLR65####027' (no error) 
YYYY-MM-DDTHH:MM:SSZ INFO: [29] Disconnected from session on vCenter 'myvcenter.com'. 
YYYY-MM-DDTHH:MM:SSZ INFO: [29] Adding FlrBrowseSessions session 'cb###4c0-7##0-4##9-b##1-711#####a983'

 

З журналу /opt/emc/vproxy/runtime/logs/vflrd/browse-cb0###c0-7##0-4##9-b##1-7116#####983.log:

YYYY-MM-DDTHH:MM:SSZ ERROR: [29] FLR:browse_files: Unable to perform FLR Agent operation 'browse_files' on VM IP Address: ##.##.##.## (vm-####). 
YYYY-MM-DDTHH:MM:SSZ ERROR: [29] Unable to retrieve file list from ##.##.##.## (vm-####) path 'F:\DFS-SHARE\Administration\MY_FOLDER' offset 0. 
YYYY-MM-DDTHH:MM:SSZ ERROR: [29] Could not get directory contents: Unable to retrieve file list from ##.##.##.## (vm-####) path '#:\DFS-SHARE\Administration\MY_FOLDER' offset 0. Unable to perform FLR Agent operation 'browse_files' on VM ##.##.##.## (vm-####). Cannot stat 'C:\Program Files (x86)\EMC\vProxy FLR Agent\flr\mountpoints\FLR65####027\02-#$\DFS-SHARE\Administration\MY_FOLDER': CreateFile C:\Program Files (x86)\EMC\vProxy FLR Agent\flr\mountpoints\FLR65####027\02-F$\DFS-SHARE\Administration\EXE_ADMIN: Access is denied. 
YYYY-MM-DDTHH:MM:SSZ ERROR: [29] FLR:browse_files: Cannot stat 'C:\Program Files (x86)\EMC\vProxy FLR Agent\flr\mountpoints\FLR65####027\02-#$\DFS-SHARE\Administration\MY_FOLDER': CreateFile C:\Program Files (x86)\EMC\vProxy FLR Agent\flr\mountpoints\FLR65####027\02-#$\DFS-SHARE\Administration\MY_FOLDER: Access is denied.

 

原因

  • Віртуальні машини, які вийшли з ладу для FLR з вищезазначеними симптомами, використовують розподілену файлову систему Microsoft (DFS).
  • Microsoft DFS — це функція файлової системи Windows, яка дозволяє користувачам створювати простір імен із спільних каталогів, які фізично розподіляються мережею. За допомогою DFS користувачі можуть логічно організувати групу розподілених каталогів за будь-якою схемою, яку вони виберуть, щоб забезпечити централізований доступ до файлів, які знаходяться в різних місцях.
  • Щоб дізнатися більше про Microsoft DFS, перегляньте статтю Microsoft Огляд просторів імен DFS. Це гіперпосилання спрямовує вас на веб-сайт за межами Dell Technologies.

 

解决方案

  • NetWorker NVP vProxy - Virtual Machine File Level Recovery (FLR) не підтримує розподілену файлову систему Windows (DFS).
  • Dell Engineering виявила, що vProxy FLR не підтримує розподілену файлову систему Microsoft (DFS)
  • Для усунення цього обмеження планується майбутній випуск NetWorker VMware Integration Guide для версій 19.8 і 19.9.

 

Спосіб вирішення:

  1. Ініціюйте відновлення на рівні файлу (FLR) з інтерфейсу NetWorker Management Console (NMC).
  2. Mount File Level Recovery (FLR) в NetWorker Management Console (NMC) UI Recovery Page Title: Змонтуйте набір збережень для відновлення на рівні файлу
  3. Залиште точку монтування File Level Recovery (FLR) у змонтованому стані в інтерфейсі NetWorker Management Console (NMC).
  4. Використовуйте Провідник Windows, щоб скопіювати та вставити вміст каталогу на цільову віртуальну машину розподіленої файлової системи (DFS).

 

文章属性
文章编号: 000217445
文章类型: Solution
上次修改时间: 16 10月 2024
版本:  4
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。