Data Domain: REST API error - REST service is disabled

摘要: How to resolve REST Application Programming Interface (API) errors.

本文章適用於 本文章不適用於 本文無關於任何特定產品。 本文未識別所有產品版本。

症狀

Identified Symptoms

The following symptoms have been identified:

  • Cyber Recovery UI errors
    • "Got HTTP response code 400 Bad Request while login to DD using REST API" error message
  • "REST service is disabled" error message when trying to connect to DD on port 3009 using browser or API call

原因

Root Cause of the Issue

The root cause of the issue is that the REST service is disabled on the Data Domain.

This can be due to the web service being disabled, which is required for the REST service to run.

  • REST service is disabled
  • Web service is disabled

Relevant Error Messages

Relevant error messages that indicate the cause of the issue include:

  • "REST service is disabled"
  • "Got HTTP response code 400 Bad Request while login to DD using REST API"
# Relevant command to check the status of the web service
$ adminaccess enable web-service

解析度

Enabling REST Service on Data Domain

To resolve the REST API error, the REST service on the Data Domain must be running. This can be achieved by enabling the web service.

# Enable web service using the following CLI command
adminaccess enable web-service

Once the web service is enabled, the REST service runs, allowing REST API calls to complete successfully.

Verifying the Resolution

To verify that the issue has been resolved, attempt to connect to the Data Domain on port 3009 using a browser or API call. If the REST service is running, the "REST service is disabled" error does not appear.

Caution: If the issues is still occurring, contact Dell Support.

受影響的產品

PowerProtect Cyber Recovery, DD OS
文章屬性
文章編號: 000353903
文章類型: Solution
上次修改時間: 07 8月 2025
版本:  1
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。