Symptoms
This issue occurred specific to this environment:
- This is a VCF setup where the upgrade of ESXi with the PowerPath/VE 7.2 live vibs was embedded in the ISO which was then pushed with the VCF upgrade having the ESXi with existing PowerPath/VE 7.1 offline bundle installed.
- When PowerPath/VE was upgraded from 7.1 (offline package) to 7.2 (live package), CIM service was stopped due to security issues and service was disabled along with the Startup policy been set to “Start and Stop manually”.
- CIM service was restarted in order to allow communication to PPMA.
- But when the ESXi was rebooted followed by CIM service start again, it seems to work.
- The issue is not consistent across all the hosts as only few of the hosts seem to have the issue and not all of them.
Cause
ESXi hosts showing up as disconnected can be due to many reasons and in this case, it was due to sfcbd not in running state.
-- As per shown in the following screenshot, the sfcbd was unable to be started even after manual restart:
Resolution
In this case, the workaround seems to be the reboot of the ESXi hosts post which the sfcbd could be started and hence the communication between the PPMA and ESXi hosts were established.
NOTE: Further troubleshooting could not be done as all the hosts in the affected datacenter were already upgraded and there were no test beds to carry out the further investigation.
Products
PowerPath/VE for VMware