Dell Unity: Users unable to access NDMP restored data due to local admin group SID changes between NDMP source and destination NAS servers
Summary: Dell Unity: Users unable to access NDMP restored data due to local admin group SID changes between NDMP source and destination NAS servers.
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Symptoms
The customer had permission issues on the restore of an NDMP backup on the top-level folder that had permissions set to allow local administrators.
Cause
This is due to the way that the local administrators SID is stored in the DACL. We use the unique SID that contains the local domain for the CIFS server. If the backup is restored to a different NAS server, the local admins SID is different due to the different local domain SID of the new NAS server, so it does not grant access.
Resolution
Fix/Workaround to avoid the issue from occurring again is to download Hot Fix Unity OE 5.2.2.0.6.200.
This hotfix is a full upgrade image, and it can be installed directly on any version of Unity.
After hotfix is installed, it is necessary to enable this new parameter: convertServerSid
/nas/bin/server_param ALL -facility PAX -modify convertServerSid -value 1
Note: This parameter does not require a reboot for this to become effective.
Affected Products
Dell EMC UnityArticle Properties
Article Number: 000215483
Article Type: Solution
Last Modified: 17 Feb 2025
Version: 4
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