Connectrix B-Series: SANnav-Unable to log in, and the Linux File System is 100 Percent Full on SANnav Versions 2.2.1, 2.2.2, 2.2.2.1, and 2.2.2a

Summary: Users are unable to log in due to full file systems on SANnav versions 2.2.1, 2.2.2, 2.2.2.1, and 2.2.2a.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Impact:
  • User unable to log in using the UI from the browser
  • Unable to use SANnav
  • Linux host file system full
Environment:
  • DELL software: Dell Connectrix SANnav 2.2.1
  • DELL software: Dell Connectrix SANnav 2.2.2
  • DELL software: Dell Connectrix SANnav 2.2.2.1
  • DELL software: Dell Connectrix SANnav 2.2.2a
Issue:
The file system filling up on the SANnav server is preventing the user from logging in.
  • Application Messages are displayed in the EVENT logs (Fault => Events)
    • SMP-SMON-1001: Disk is 70% full (INFO)
    • SSMP-SMON-1002: Disk is 80% full (WARNING)
    • SSMP-SMON-1003: Disk is 90% full (CRITICAL)
(The possibility is available to configure an event action policy to receive an email when these events occur to minimize the risk of missing the events.)
  • The script "check-sannav-status.sh" indicates that all services are down.
Specific requirements:
This issue is only reported when Gen7 switches are discovered.
  • Dell Hardware: Connectrix ED-DCX7-4B
  • Dell Hardware: Connectrix ED-DCX7-8B
  • Dell Hardware: Connectrix DS-7730B
  • Dell Hardware: Connectrix DS-7720B

Cause

SANnav collects flow metrics from the switches and stores the metrics in temp files for further processing. The temp files are supposed to be deleted after processing the data.

An issue in the code prevents the files from being deleted. As this continues, the file system fills up.

As this issue only manifests with GEN7 switches in the environment, disk usage depends on the number of GEN7 switches and chassis managed in SANnav.

Resolution

Resolution:

  • For new installations or upgrades of SANnav v2.2.2.1 and v2.2.2a, follow the process mentioned in the Release Notes for new installations or upgrades of SANnav v2.2.2.1 and v2.2.2a.
  • If the SANnav is already installed or upgraded to the impacted version, perform the steps in the Workaround to resolve the issue.


Workaround:

  • SANnav v2.2.1
  1. Log in as root or sudo.
  2. Stop SANnav using the following script:
    <SANnav Home>/Portal_2.2.1_bld202/bin/stop-sannav.sh
  3. Add the following line at the end of the server.properties file present in the folder "<SANnav Home>/Portal_2.2.1_bld202/conf"DCM_CONTAINER_HOME=/dcm1.0.0/temp/flow_mgmt_stats"
  4. Start SANnav using below script.
    <SANnav Home>/Portal_2.2.1_bld202/bin/start-sannav.sh
  • SANnav v2.2.2 or v2.2.2.1
  1. Log in as root or sudo
  2. Stop SANnav using below script.
    <SANnav Home>/Portal_2.2.2_bld113/bin/stop-sannav.sh
  3. Add the following line at the end of the server.properties file present in the folder "<SANnav Home>/Portal_2.2.2_bld113/conf"DCM_CONTAINER_HOME=/dcm1.0.0/temp/flow_mgmt_stats"
  4. Start SANnav using below script.
    <SANnav Home>/Portal_2.2.2_bld113/bin/start-sannav.sh  
  • SANnav v2.2.2a
  1.  Log in as root or sudo
  2. Stop SANnav using below script.
    <SANnav Home>/Portal_2.2.2a_bld038/bin/stop-sannav.sh
  3. Add the following line at the end of the server.properties file present in the folder "<SANnav Home>/Portal_2.2.2a_bld038/conf"DCM_CONTAINER_HOME=/dcm1.0.0/temp/flow_mgmt_stats"
  4. Start SANnav using below script.
    <SANnav Home>/Portal_2.2.2a_bld038/bin/start-sannav.sh
  • SANnav v2.3.0
No action is required, SANnav v2.3.0 already contains the necessary configuration.
 
NOTE:
  1. If a backup is restored prior to making the above changes, then ensure to reapply the above procedure again after restoring the SANnav backup.
  2. After performing the above-mentioned procedure, and after all the services are up and running (~15 minutes), the old temp files are automatically purged.

Affected Products

Connectrix
Article Properties
Article Number: 000217906
Article Type: Solution
Last Modified: 29 Jul 2025
Version:  5
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