Missing Peripheral or Dock in Dell Device Management Agent
Résumé: Learn about what to do if Dell Device Management Agent version 2.2.2 fails to display docks or peripherals other than monitors.
Symptômes
Dell Device Management Agent may fail to display connected docks or peripherals. When this happens, monitors are still displayed. Connected docks and peripherals are still displayed in Dell Display and Peripheral Manager.
Affected Platforms:
- Dell Device Management Agent version 2605 (26.05.0.1066)
- Dell Display and Peripheral Manager version 2.2.2.8
Cause
A dependency between Dell Device Management Agent and Dell Display and Peripheral Manager causes this issue.
Résolution
- Back up all personal data. For more information, refer to Back Up and Recovery.
- Connect the AC adapter if updates are being run on a laptop.
- Ensure that power remains connected if updates are being run on a desktop.
Updating Dell Display and Peripheral Manager to version 2.2.2.8 and later and updating Dell Device Management Agent to version 26.05.0.1066 and later on the computer resolves the issue. To download and install Dell Display and Peripheral Manager and the Dell Device Management Agent, refer to the Dell Display and Peripheral Manager for Windows User’s Guide at Support for Dell Display and Peripheral Manager Manuals & Documents and refer to How to Install the Dell Device Management Agent on a Host Computer.