Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products

RecoverPoint for Virtual Machines: ERROR: User volume

Summary: Consistency Group (CG) goes into an error state due to one or more devices being removed from the production Virtual Machine (VM). Error received is [CG name, Copy, CG_RSET_VM_NAME.copy.shadow_x_x_scsi] cannot be accessed by: RPA 1, RPA 2 ...

This article applies to   This article does not apply to 

Symptoms

One or more VMDKs were removed from the production Virtual Machine (VM).

RecoverPoint has errors seen in the logs:
CLI:
ERROR: User volume [CG name, Copy, CG_RSET_VM_NAME.copy.shadow_x_x_scsi] cannot be accessed by: RPA 1, RPA 2
ERROR: User volume [CG name, Copy, CG_RSET_VM_NAME-1.copy.shadow_x_x_scsi] cannot be accessed by: RPA 1, RPA 2
The above ERROR has the below in order to be relevant for this article.
ERROR: The VMDKs of VMs in production group [CG name, Remote Copy Name] are not identical to their copies (VM_NAME_scsix:x size:size, VM_NAME-1_scsix:x size:size). There are VMDKs missing from production. Add VMDKs with the same port type and ID and the same size as the original (which causes a volume sweep), or unprotect and reprotect the production VMs (which causes journal loss and full sweep).

Cause

One or more VMDKs were removed from the production VM, however RecoverPoint still has the settings for the missing devices.

Resolution

Steps:
 
Note: Before applying this fix, get the customer's permission!
 
  1. From the RecoverPoint Plugin of the source site, on the Protection tab, select Protected VMs.
  2. Choose the impacted VM (the VM name is found above ERROR: User volume)
  3. Click Protection Policy and clear the blank VMDKs (No name, 0B in size).
Protection Policy of VM Windows-Test-81
  1. Select UPDATE POLICY

Additional Information

Note: This issue may occur when using PowerProtect Transparent Snapshot Manager during File-level restore operation. This is because the operation adds a VMDK and later removes it.

Workaround:
Customers may choose to clear the option: Automatically protect newly added VMDKs in the RecoverPoint protected VMs policy.
Protection Policy of VM Windows Test-81 with Automatically protect newly added VMDKs selected
 

Affected Products

RecoverPoint for Virtual Machines

Products

PowerProtect Data Manager Software, RecoverPoint for Virtual Machines