NetWorker: NMM SQL backup failure after upgrade to 19.13.0.2 - No Active SQL Server found.
Summary: NMM SQL backup failure after upgrade to 19.13.0.2 - No Active SQL Server found.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Customer was running NMM 19.10, and backups were running successfully.
After upgrading to 19.13.0.2 backups failed with errors:
98188: nsrsqlsv: No Active SQL Server found.
98921: nsrsqlsv: Failed to get preferred node for backup of Availability group (xxxxxxxxxxx) with error: [bsGetPreferredNodeOnCurrentNode]: Availability Group (xxxxxxxxxxx) not found on node..
38008: nsrsqlsv: SSL Provider: The certificate chain was issued by an authority that is not trusted.
Cause
(After NMM version 19.10, changes were made to the code in relation to DNS and rDNS)
Resolution
Steps taken to fix the issue:
- Added host file entries (IP, FQDN, Short name) on the backup server's hosts file for Cluster instance, each node, backup server, and Data Domain.
- Added host file entries (IP, FQDN, Short name) on both nodes hosts file for Cluster instance, each node, backup server and Data Domain.
- If OLE database drivers installed are version 18.x o19.x, Enable Flag 2 by setting to 1.
- Perform upgrade.
- Clear peer information from backup server and SQL nodes.
- Run backup. Backups were then successful.
Affected Products
NetWorker ModuleProducts
NetWorker Family, NetWorker, NetWorker Module for MicrosoftArticle Properties
Article Number: 000429113
Article Type: Solution
Last Modified: 18 فبراير 2026
Version: 1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.