NetWorker: NMC UI "Unable to launch application", Unsigned application requesting unrestricted access to system
Oversigt: When launching NetWorker Management Console (NMC), the UI fails to launch with "Unable to launch application" error.
Denne artikel gælder for
Denne artikel gælder ikke for
Denne artikel er ikke knyttet til et bestemt produkt.
Det er ikke alle produktversioner, der er identificeret i denne artikel.
Symptomer
- When launching NetWorker Management Console (NMC), the user interface fails to launch with "Unable to launch application".
- The Details tab reports the following error:
Error: Unsigned application requesting unrestricted access to system
Unsigned resource https://<NMC server>:9000/LGTOnmc/java/comtsk.jar
Unsigned resource https://<NMC server>:9000/LGTOnmc/java/comtsk.jar
Årsag
From the Java 8 Update 131 release, applications signed with the MD5withRSA or MD5withDSA algorithms are treated as unsigned.
Løsning
1. Edit the java.security file under the NRE installation security path.
For NRE, the full path to the file is C:\Program Files\NRE\java\<jre version>\lib\security\java.security.
2. Comment out the line that starts with "jdk.jar", like in the example below-
4. Launch NMC UI.
For NRE, the full path to the file is C:\Program Files\NRE\java\<jre version>\lib\security\java.security.
2. Comment out the line that starts with "jdk.jar", like in the example below-
# jdk.jar.disabledAlgorithms=MD2, MD5, RSA keySize < 1024, \
# DSA keySize < 1024, include jdk.disabled.namedCurves 3. Save the changes.
4. Launch NMC UI.
Berørte produkter
NetWorker, NetWorker Management ConsoleProdukter
NetWorker Family, NetWorker SeriesArtikelegenskaber
Artikelnummer: 000210820
Artikeltype: Solution
Senest ændret: 28 maj 2023
Version: 2
Find svar på dine spørgsmål fra andre Dell-brugere
Supportservices
Kontrollér, om din enhed er dækket af supportservices.