PowerMax 2500 和 8500:主机无法使用 NVMe/TCP 发现 PowerMax

Oversigt: 在通告直接发现控制器 (DDC) 模式下配置 PowerMax 上的 NVMe/TCP 端点 (IPPT) 时,主机无法发现并连接到 PowerMax。

Denne artikel gælder for Denne artikel gælder ikke for Denne artikel er ikke knyttet til et bestemt produkt. Det er ikke alle produktversioner, der er identificeret i denne artikel.

Symptomer

受影响的 PoweMaxOS 级别: 
  • 10.0.0.0 (Juniper)
  • 10.0.1.0 (Juniper-SR1)
  • 10.0.1.x (Juniper-SR1-热修复程序)
这会影响使用 nvme-stas 或使用 mDNS 查找和连接到 PowerMax 的类似工具的主机。


Linux 主机上的以下命令可以查找通告的服务:

 
avahi-browse -t -v _nvme-disc._tcp
 
image.png

使用以下命令解决域(选项 -r)失败的问题。
avahi-browse -t -r -v _nvme-disc._tcp
 
image.png

Årsag

问题是域名服务器 (DNS) 记录服务记录 (SRV)https://en.wikipedia.org/wiki/SRV_record)。
SRV 记录有一个名为“target”的字段,目标是提供服务的实体的主机名。主机可以使用该主机名检索 IP 地址。在 PowerMax 中,该机制不起作用,因为“目标”指向错误的主机名,如以下查询响应中所示。

image.png
 

除上述问题外,在构建查询响应时,由格式化问题导致的查询响应中资源记录RR_TXT为空。

Løsning

通过 Juniper-SR1-Hotfix:
10.0.1.x (Juniper-SR1-hotfix) - PMOS-59142 上的以下修复解决了此问题

解决方法
手动配置 DDC IP 地址,即与主机上的 IPPT 关联的 IP 地址。

Berørte produkter

PowerMax 2500, PowerMax 8500
Artikelegenskaber
Artikelnummer: 000217103
Artikeltype: Solution
Senest ændret: 18 maj 2026
Version:  7
Find svar på dine spørgsmål fra andre Dell-brugere
Supportservices
Kontrollér, om din enhed er dækket af supportservices.