Dell EMC Unity: Error 0x100000a while trying to upload .gpg upgrade image with uemcli -upload (Dell EMC correctable)
Summary: Uploading files to Dell EMC Unity via UEMCLI fail for a lack of space on the Unity partitions, however there is adequate free space on the Unity system.
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This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Dell EMC Unity OE Upgrade
Attempting to upgrade the Dell EMC Unity array using Windows UEMCLI fails with a generic 0x100000a error. This is posted as "There is not enough free disk space on the client machine to complete this operation" and it may also be seen as Error Code:0x100000a or Error Code:0x1000102
C:\Users\admin>uemcli ... -upload -f Unity-4.0.2.8627717.tgz.bin.gpg upgrade
Exit code: 1
Output: Operation failed. Error code: 0x100000a
The system was unable to connect to the storage server. (Error Code:0x100000a)
Attempting to upgrade the Dell EMC Unity array using Windows UEMCLI fails with a generic 0x100000a error. This is posted as "There is not enough free disk space on the client machine to complete this operation" and it may also be seen as Error Code:0x100000a or Error Code:0x1000102
C:\Users\admin>uemcli ... -upload -f Unity-4.0.2.8627717.tgz.bin.gpg upgrade
Exit code: 1
Output: Operation failed. Error code: 0x100000a
The system was unable to connect to the storage server. (Error Code:0x100000a)
Even in the Dell EMC Unity array :
service@(none) spb:/$ uemcli ... -upload -f Unity-4.0.2.8627717.tgz.bin.gpg upgrade
Uploaded 1.94 GB of 1.94 GB [ 100.0% ] at 36.44 MB/s
Operation failed. Error code: 0x100000a
The system was unable to connect to the storage server. (Error Code:0x100000a)
Cause
The Dell EMC Unity system needs two and half times more space of the upgrade image in these partitions:
/cores
/var/tmp (which is from root partition, "/")
Say if the OE image is 2GB, then we need 5GB free space in /cores and about same in /var/tmp. On /var/tmp, it can try to free up old images, but /cores if not enough space, it will fail with error 0x1000000a.
/cores
/var/tmp (which is from root partition, "/")
Say if the OE image is 2GB, then we need 5GB free space in /cores and about same in /var/tmp. On /var/tmp, it can try to free up old images, but /cores if not enough space, it will fail with error 0x1000000a.
Resolution
Enable SSH on the Dell EMC Unity system, then login as the "service" user.
DO NOT run svc_purge_logs -c --force (this may result in unexpected SP reboots and even Data Unavailable).
From svc_purge_logs -help:
--clear[-c] --force Attempts to clear space on the root filesystem.
Files will not be removed unless --force is used.
WARNING: Using this option could cause irreversible
damage to the system.
Once logged into the Unity array, issue a "df -h", to ensure that there is at least 4.5GB of space free on the "/" partition. If there is not, then inspect the internal partitions with df and du commands.
You may also run svc_purge_logs -f inspect the resulting fs usage reports. Delete unwanted files carefully IF you know for sure they are not required.
If there is at least 4.5GB of free space on the "/" partition, then there is a chance you have run into a problem with the UEMCLI large file transfer functionality. There is an issue on Windows based UEMCLI Version 4.0.x that effects the ability to upload files near 2GB in size (this is a 32bit limitation).
Here is how to validate your UEMCLI install on your local windows system.
C:\Users\admin>uemcli -v
Version: 4.0.0.1.2825
Branch: upc-Unity.2.8
Revision: 308352
To proceed from here:
If this issue is occurring on the uemcli on Dell EMC Unity array, most common reason is that the /cores partition does not have at least 5Gb of free space.
If the array is UnityVSA (virtual) the user must use Unisphere GUI or remote unity system to do the upgrade. If this is Unity Hardware, peer SP can be used as below:
Procedure to upgrade using peer SP on Unity (Hardware models):
DO NOT run svc_purge_logs -c --force (this may result in unexpected SP reboots and even Data Unavailable).
From svc_purge_logs -help:
--clear[-c] --force Attempts to clear space on the root filesystem.
Files will not be removed unless --force is used.
WARNING: Using this option could cause irreversible
damage to the system.
Once logged into the Unity array, issue a "df -h", to ensure that there is at least 4.5GB of space free on the "/" partition. If there is not, then inspect the internal partitions with df and du commands.
You may also run svc_purge_logs -f inspect the resulting fs usage reports. Delete unwanted files carefully IF you know for sure they are not required.
If there is at least 4.5GB of free space on the "/" partition, then there is a chance you have run into a problem with the UEMCLI large file transfer functionality. There is an issue on Windows based UEMCLI Version 4.0.x that effects the ability to upload files near 2GB in size (this is a 32bit limitation).
Here is how to validate your UEMCLI install on your local windows system.
C:\Users\admin>uemcli -v
Version: 4.0.0.1.2825
Branch: upc-Unity.2.8
Revision: 308352
To proceed from here:
- Upgrade the windows uemcli version to the latest available from the support pages.
- Run uemcli from peer SP if upgrading uemcli on windows is not possible
- Use Unisphere GUI
If this issue is occurring on the uemcli on Dell EMC Unity array, most common reason is that the /cores partition does not have at least 5Gb of free space.
If the array is UnityVSA (virtual) the user must use Unisphere GUI or remote unity system to do the upgrade. If this is Unity Hardware, peer SP can be used as below:
Procedure to upgrade using peer SP on Unity (Hardware models):
- SSH Login to the array using service account [Example: SPA is the managing SP and SPB is peer/secondary SP ]
- Get the upgrade image file using winSCP or sftp to /cores/service (Attention: from Unity OE 4.5, use /cores/service/user instead)
- Copy the image from the primary SP to the peer/secondary SP:
Up to Unity OE 4.4.x: scp /cores/service/Unity-4.x.x.xxxxxxx.tgz.bin.gpg peer:/cores/service
From Unity OE 4.5.x: scp /cores/service/user/Unity-4.x.x.xxxxxxx.tgz.bin.gpg peer:/cores/service/user
From Unity OE 4.5.x: scp /cores/service/user/Unity-4.x.x.xxxxxxx.tgz.bin.gpg peer:/cores/service/user
- Delete the image from local SP (SPA in this example) : rm /cores/service/Unity-4.x.x.xxxxxxx.tgz.bin.gpg
- ssh to peer SP : ssh peer
- Do the upload using uemcli : uemcli -d peer -u admin -securepassword -no -upload -f /path/to/gpgfile upgrade
- Start the upgrade when required using uemcli or unisphere gui as per schedule
Additional Information
Example of uploading image file using peer SP:
service@(none) spa:~$ sftp anonymous@ftp.emc.com
sftp> get Unity-4.1.2.9257522.tgz.bin.gpg
Fetching /pub/rcm/Unity/Unity-4.1.2.9257522.tgz.bin.gpg to Unity-4.1.2.9257522.tgz.bin.gpg
/pub/rcm/Unity/Unity-4.1.2.9257522.tgz.bin.gpg 100% 2042MB 5.8MB/s 05:54
sftp> bye
service@(none) spa:~$ scp /cores/service/Unity-4.1.2.9257522.tgz.bin.gpg peer:/cores/service (for Unity OE 4.5 or above, use /cores/service/user instead)
Unity-4.1.2.9257522.tgz.bin.gpg
service@(none) spa:~$ ssh peer
Last login: Mon May 22 22:39:10 2017 from 128.221.255.100
service@(none) spb:~$ uemcli -d peer -u admin -securepassword -no -upload -f /cores/service/Unity-4.1.2.9257522.tgz.bin.gpg upgrade
(for Unity OE 4.5 or above, use /cores/service/user instead)
Password:
Uploaded 1.99 GB of 1.99 GB [ 100.0% ] -PROCESSING-
Operation completed successfully.
service@(none) spb:~$ logout
Connection to peer closed.
service@(none) spa:~$ uemcli /sys/soft/ver show -detail
1: ID = INST_1
Type = installed
Version = 4.1.1.9138882
Release date = 2017-02-09 14:30:02
Image type =
Reboot required =
Pause allowed =
Image filename =
2: ID = CAND_1 <--- upgrade image is ready to proceed
Type = candidate
Version = 4.1.2.9257522
Release date = 2017-04-11 04:23:24
Image type = software
Reboot required = yes
Pause allowed = yes
Image filename = Unity-4.1.2.9257522.tgz.bin
service@(none) spa:~$ sftp anonymous@ftp.emc.com
sftp> get Unity-4.1.2.9257522.tgz.bin.gpg
Fetching /pub/rcm/Unity/Unity-4.1.2.9257522.tgz.bin.gpg to Unity-4.1.2.9257522.tgz.bin.gpg
/pub/rcm/Unity/Unity-4.1.2.9257522.tgz.bin.gpg 100% 2042MB 5.8MB/s 05:54
sftp> bye
service@(none) spa:~$ scp /cores/service/Unity-4.1.2.9257522.tgz.bin.gpg peer:/cores/service (for Unity OE 4.5 or above, use /cores/service/user instead)
Unity-4.1.2.9257522.tgz.bin.gpg
service@(none) spa:~$ ssh peer
Last login: Mon May 22 22:39:10 2017 from 128.221.255.100
service@(none) spb:~$ uemcli -d peer -u admin -securepassword -no -upload -f /cores/service/Unity-4.1.2.9257522.tgz.bin.gpg upgrade
(for Unity OE 4.5 or above, use /cores/service/user instead)
Password:
Uploaded 1.99 GB of 1.99 GB [ 100.0% ] -PROCESSING-
Operation completed successfully.
service@(none) spb:~$ logout
Connection to peer closed.
service@(none) spa:~$ uemcli /sys/soft/ver show -detail
1: ID = INST_1
Type = installed
Version = 4.1.1.9138882
Release date = 2017-02-09 14:30:02
Image type =
Reboot required =
Pause allowed =
Image filename =
2: ID = CAND_1 <--- upgrade image is ready to proceed
Type = candidate
Version = 4.1.2.9257522
Release date = 2017-04-11 04:23:24
Image type = software
Reboot required = yes
Pause allowed = yes
Image filename = Unity-4.1.2.9257522.tgz.bin
Affected Products
Dell EMC Unity FamilyProducts
Dell Unity 300, Dell EMC Unity 300F, Dell EMC Unity 400, Dell EMC Unity 400F, Dell EMC Unity 500, Dell EMC Unity 500F, Dell EMC Unity 600, Dell EMC Unity 600F, Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Family
, Dell EMC Unity Hybrid, Dell EMC UnityVSA Professional Edition/Unity Cloud Edition
...
Article Properties
Article Number: 000052819
Article Type: Solution
Last Modified: 12 Dec 2025
Version: 3
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