NVP vProxy: Unable to find identity (MORef) of vProxy's virtual machine: Unable to determine network interface

Summary: NetWorker VMware Protection (NVP) vProxy VM backups fail with an error message "Backup has FAILED:  Unable to find identity (MORef) of vProxy's virtual machine: Unable to determine network interface" ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The NetWorker VMware Protection integration is configured with the vProxy Appliance.  The vProxy was successfully registered in the NetWorker Management Console (NMC), but all the backup sessions fail against the vProxy.  The backup session log shows:
"Backup has FAILED:  Unable to find identity (MORef) of vProxy's virtual machine: Unable to determine network interface"

Cause

The vProxy is configured with a second Network Interface Card that has no IP address assigned.

Running ifconfig as root user shows the NIC with no IP address.
eth1 Link encap:Ethernet HWaddr XX:XX:XX:XX:XX:XX
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

Resolution

Option 1:
Remove the Network interface that has no IP address and restart the vProxy.  

Option 2:
Configure the unused NIC: NVP vProxy: How to manually change the vProxy Appliance network interface settings

Additional Information

Products

NetWorker
Article Properties
Article Number: 000169322
Article Type: Solution
Last Modified: 15 Nov 2023
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.