NVP-vProxy: Unable to find identity (MORef) of vProxy's virtual machine
Summary: NetWorker VMware Protection (NVP) Virtual Machine (VM) backups failing with "Unable to find identity (MORef) of vProxy's virtual machine: Failed to find the virtual machine for vProxy "IP_ADDRESS"" ...
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Symptoms
The vProxy virtual machine (VM) backups are failing with:
Unable to find identity (MORef) of vProxy's virtual machine: Failed to find the virtual machine for vProxy "IP_ADDRESS"
Cause
The VMware vCenter function to find the VM Managed Object Reference (MoRef) by IP is not working.
Resolution
The find virtual machine MoRef by IP symptom must be resolved in the environment. Here is a method to find the virtual machine MoRef outside of the vProxy workflow:
- Connect to the vCenter Managed Object Browser (MOB) using your web browser: https://vcenter_name_or_ip/mob
NOTE: Ensure to use a resolvable hostname or IP address for your vCenter server. You are required to enter the vCenter administrator credentials (e.g: administrator@vsphere.local). If you cannot access vCenter MOB, share the full error and this KB article with your vCenter admin to help investigate the issue.
- Collect the Datacenter MoRef value:
- Select content in the MOB main screen.
- Under rootFolder select the (Datacenters) link next to ManagedObjectReference:Folder:
)
- This shows the MoRef of the data center:
- In the web browser url, enter:
https://vcenter_name_or_ip/mob/?moid=SearchIndex&method=findByIp- In the data center box, replace MOID with the MoRef of the data center collected in step 2, c.
- In the ip (string) box, enter the IP address of the vProxy reported in the error message.
- In the vmSearch (boolean) box, enter true.
- Select Invoke Method.
The following example shows a successful search result:
Additional Information
If the lookup fails to return or is incorrect, the MORef function to find the vProxy by IP is not working correctly in the vCenter environment. This is a non-NetWorker issue and must be corrected in the vCenter environment. If required, contact VMware Support for further assistance in resolving the symptom.
Affected Products
NetWorkerProducts
NetWorker FamilyArticle Properties
Article Number: 000031279
Article Type: Solution
Last Modified: 20 June 2025
Version: 4
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