PowerScale: Users Fail to Access SMB Share Due to Password Failure After Upgrade

Summary: PowerScale: Local users fail to access SMB share due to password failure after upgrade to OneFS 9.5 or later version from pre-9.5.x code.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

After the OneFS upgrade to 9.5.0.0-9.10.1.4 versions from pre-9.5.x code, the cluster local users fail to access SMB share with an error message like:

The specified network password is not correct.

NOTE: The issue only impacts the cluster local users. It may impact other protocol access too.

 

Cause

The issue is caused by how the local users' passwords are stored on the cluster after the code change to OneFS 9.5.x. Local users' passwords are converted to a more secure hash after the upgrade.

When a local user's password contains certain special characters, the password cannot be automatically converted to use the new hash. This requires you to update the password manually. 

Resolution

There are two methods for identifying impacted local users:

1) You can identify users whose passwords need to be reset by searching for messages in lsassd.log:

[lsass] 1234 password is not properly upgraded. Please reset the password at the earliest for this UID.

2) You can run the healthcheck "null_mcf_hash", included in auth and security healthcheck lists.

The cluster admin can manually reset the password for the impacted local users.
 

Article Properties
Article Number: 000225723
Article Type: Solution
Last Modified: 13 Nov 2025
Version:  10
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.