PowerScale: Users Fail to Access SMB Share Due to Password Failure After Upgrade
Summary: PowerScale: Local users fail to access SMB share due to password failure after upgrade to OneFS 9.5 or later version from pre-9.5.x code.
Symptoms
After the OneFS upgrade to 9.5.0.0-9.10.1.4 versions from pre-9.5.x code, the cluster local users fail to access SMB share with an error message like:The specified network password is not correct.
NOTE: The issue only impacts the cluster local users. It may impact other protocol access too.
Cause
The issue is caused by how the local users' passwords are stored on the cluster after the code change to OneFS 9.5.x. Local users' passwords are converted to a more secure hash after the upgrade.
When a local user's password contains certain special characters, the password cannot be automatically converted to use the new hash. This requires you to update the password manually.
Resolution
There are two methods for identifying impacted local users:
1) You can identify users whose passwords need to be reset by searching for messages in lsassd.log:
[lsass] 1234 password is not properly upgraded. Please reset the password at the earliest for this UID.
2) You can run the healthcheck "null_mcf_hash", included in auth and security healthcheck lists.
The cluster admin can manually reset the password for the impacted local users.