PowerFlex 3.X Gateway UI Does Not Open, Receive a 404 Error
Summary: PowerFlex 3.x UI is inaccessible, receive a 404 error when trying to open it. PowerFlex 3.x is reachable from the CLI.
Symptoms
PowerFlex Gateway UI became inaccessible, however the gateway was reachable from CLI.
The PowerFlex Gateway UI is returning the error:
HTTP Status 404 - Not Found Type Status Report Description The origin server did not find a current representation for the target resource or is not willing to disclose that one exists. Apache Tomcat/8.5.65

Cause
The root cause here is that the file /opt/emc/scaleio/gateway/webapps/ROOT/WEB-INF/classes/gatewayUser.properties is not in a good format. There are missing parts to it, in this case at the bottom.
Resolution
Analyzed the logs and file under /opt/emc/scaleio/gateway and found that the file /opt/emc/scaleio/gateway/webapps/ROOT/WEB-INF/classes/gatewayUser.properties was corrupted.
The file is missing parts at the bottom:

This file must be restored either from a backup or by comparing it with a similar file from another cluster.
Once this is done, restart the gateway service:
#systemctl restart scaleio-gateway
Related article:
See article The 404 Error Seen From PowerFlex Gateway which discusses a similar issue to this file causing a 404 error too.