NetWorker: NWUI Browsable Recovery chiede l'autorizzazione ChangeSecuritySettings o ViewSecuritySettings
Summary: Quando si esegue un ripristino esplorabile in NWUI, non è possibile sfogliare manualmente i file da ripristinare se l'utente connesso a NWUI non dispone dell'autorizzazione ChangeSecuritySettings o ViewSecuritySettings. ...
Symptoms
-
Esecuzione di un ripristino esplorabile in NWUI con un utente appartenente al gruppo "operators":

Figura 1. NWUI - Visualizzazione Recover e Savesets
Figura 2. NWUI - Selezione del ripristino a livello di file -
Se si clicca su "browse" qui per individuare i file da ripristinare, viene visualizzato l'errore:

Figura 3. Procedura guidata di ripristino - Vista pulsante Browse
Figura 4. Procedura guidata di ripristino - Errore dopo aver cliccato sul pulsante Browse della Figura 3Il messaggio di errore è:
Could not get directory contents. Permission denied. User <user> has no ChangeSecuritySettings or ViewSecuritySettings privilege.
L'utente non deve aver bisogno di tale autorizzazione per eseguire un ripristino esplorabile. NMC, ad esempio, non lo richiede.
Per il momento, se è necessario eseguire questa operazione in NWUI, è necessario concedere all'utente il privilegio ViewSecuritySettings . -
Questo problema non impedisce l'esecuzione del ripristino; Evita solo di selezionare i file da recuperare. Avremmo potuto inserire manualmente il percorso per il ripristino:

Figura 5. Procedura guidata di ripristino: inserimento manuale di un percorso da cui eseguire il ripristino. -
Cliccare su Next ed eseguire correttamente il ripristino.

Figura 6. Procedura guidata di ripristino - Opzione di configurazione di base in cui è possibile selezionare un percorso per il ripristino utilizzando il pulsante Sfoglia. -
Nella schermata precedente, fallisce di nuovo se facciamo clic su "SFOGLIA", ma ciò non ci impedisce di inserire manualmente il percorso in cui vogliamo indirizzare i nostri file.

Figura 7. Procedura guidata di ripristino: ripristino riuscito quando si immettono manualmente i percorsi da/verso cui eseguire il ripristino.Dopo aver cliccato su "Finish", possiamo verificare che la scheda "recover jobs" indichi che è completato:

Figura 8. NWUI: la vista Recover Jobs che mostra il nostro ripristino inserendo manualmente i percorsi da/a per il ripristino è stato eseguito correttamente.
Cause
Questo problema è stato causato da un difetto del codice: NETWORKER-91941
Resolution
A partire da oggi, non esiste una versione con la correzione.