NetWorker: NWUI Browsable Recovery chiede l'autorizzazione ChangeSecuritySettings o ViewSecuritySettings

Summary: Quando si esegue un ripristino esplorabile in NWUI, non è possibile sfogliare manualmente i file da ripristinare se l'utente connesso a NWUI non dispone dell'autorizzazione ChangeSecuritySettings o ViewSecuritySettings. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • Esecuzione di un ripristino esplorabile in NWUI con un utente appartenente al gruppo "operators":
    Elenco di ripristini e saveset da NWUI
    Figura 1. NWUI - Visualizzazione Recover e Savesets

    Selezione del ripristino a livello di file
    Figura 2. NWUI - Selezione del ripristino a livello di file

  • Se si clicca su "browse" qui per individuare i file da ripristinare, viene visualizzato l'errore:
    Procedura guidata di ripristino NWUI che mostra l'opzione BROWSE
    Figura 3. Procedura guidata di ripristino - Vista pulsante Browse

    Errore riscontrato nella procedura guidata di ripristino dopo aver selezionato l'opzione BROWSE
    Figura 4. Procedura guidata di ripristino - Errore dopo aver cliccato sul pulsante Browse della Figura 3

    Il messaggio di errore è:

    Could not get directory contents.
    Permission denied. User <user> has no ChangeSecuritySettings or ViewSecuritySettings privilege.

     

    L'utente non deve aver bisogno di tale autorizzazione per eseguire un ripristino esplorabile. NMC, ad esempio, non lo richiede.
    Per il momento, se è necessario eseguire questa operazione in NWUI, è necessario concedere all'utente il privilegio ViewSecuritySettings .

  • Questo problema non impedisce l'esecuzione del ripristino; Evita solo di selezionare i file da recuperare. Avremmo potuto inserire manualmente il percorso per il ripristino:
    Percorso di ripristino della procedura guidata di ripristino immesso manualmente come soluzione alternativa
    Figura 5. Procedura guidata di ripristino: inserimento manuale di un percorso da cui eseguire il ripristino.

  • Cliccare su Next ed eseguire correttamente il ripristino.
    Procedura guidata di ripristino - Passaggio di configurazione di base
    Figura 6. Procedura guidata di ripristino - Opzione di configurazione di base in cui è possibile selezionare un percorso per il ripristino utilizzando il pulsante Sfoglia.

  • Nella schermata precedente, fallisce di nuovo se facciamo clic su "SFOGLIA", ma ciò non ci impedisce di inserire manualmente il percorso in cui vogliamo indirizzare i nostri file.
    Procedura guidata di ripristino - Riepilogo
    Figura 7. Procedura guidata di ripristino: ripristino riuscito quando si immettono manualmente i percorsi da/verso cui eseguire il ripristino.

    Dopo aver cliccato su "Finish", possiamo verificare che la scheda "recover jobs" indichi che è completato:
    Job di ripristino: tentativo riuscito dopo l'inserimento manuale dei percorsi da ripristinare
    Figura 8. NWUI: la vista Recover Jobs che mostra il nostro ripristino inserendo manualmente i percorsi da/a per il ripristino è stato eseguito correttamente.

 

Cause

Questo problema è stato causato da un difetto del codice: NETWORKER-91941

 

Resolution

A partire da oggi, non esiste una versione con la correzione.

 

Article Properties
Article Number: 000222868
Article Type: Solution
Last Modified: 25 Apr 2024
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.