SupportAssist Flickers When Dragged to External Display
Summary: The SupportAssist application flickers when moved by dragging to an external monitor in extended mode.
Symptoms
SupportAssist application flickers as dragged to an external monitor. The flickering only occurs when using extended mode. Flickering occurs only while dragging the SupportAssist application, once SupportAssist has been dragged to an external monitor the flicking stops.
Affected Platforms:
- Dell Pro Rugged 10 Tablet RA00260
- Dell Pro Rugged 12 Tablet RA02260
Cause
SupportAssist application flickers as dragged to an external monitor. The symptom is only present on extended mode. Flickering occurs only while dragging the SupportAssist application, once SupportAssist has been dragged to an external monitor the flicking stops.
Resolution
Workaround:
Changing the display mode to duplicate mode to Show only on 1 or Show only on 2 is a workaround to resolve the flickering issue. Follow the steps below to change the display mode.
- Right click screen.
- Select Display settings.
- Change the setting to Show only on 1 or Show only on 2.
- Select Keep changes.
Resolution:
The engineering department is working on a fix to be released in SupportAssist version 5 and later. The update for SupportAssist is posted to the computer's support page once it is made available. SupportAssist version 5 is expected to be released in January or February 2026.