PowerProtect: Unable to deploy VM Direct Protection Engine due to initialization failure
Summary: The Virtual Machine (VM) Direct Engine deployment fails to initialize with Unable to connect to External vProxy over port 9090 message.
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Symptoms
The PowerProtect Data Manager appliance is used to protect the vSphere environment with the VM Direct Engine solution. The VM Direct Engine deployment in a demilitarized zone (DMZ) cluster fails during the initialization phase. The System Job status shows:
ProxySession unsuccessful during initialization. Unable to deploy and verify the vProxy my-proxy.my-domain.com. Unable to query vProxy status after 'Deploy'. Request unsuccessful. Unable to connect to External vproxy 'my-proxy.my-domain.com' on port '9090', the host service is not running. Action : Deploy TransportMode : HotaddPreferred Vproxy : my-proxy.my-domain.com Error : ProxySession unsuccessful during initialization. Unable to deploy and verify the vProxy my-proxy.my-domain.com. Unable to query vProxy status after 'Deploy'. Request unsuccessful. Unable to connect to External vproxy 'my-proxy.my-domain.com' on port '9090', the host service is not running. (0) ProtectionType : VM VproxyStatus : Failed
The /var/log/brs/vmdm/vmdm.log shows:
YYYY-MM-DD20:37:02.229Z ERROR [] [vproxyMonitor] [][][][TRACE_ID:b28dabec92e4fcae][] [c.e.b.v.v.s.VPEProxyService.updateTask(809)] - Update VM Direct Protection Engine failed 40be4802-972d-416f-b131-43890b6c32ac ManagedProxySession(state=Failure, id=32a99bf2-1c6e-47e7-aff1-4b26b7026cc8, error: code=0, text=ProxySession unsuccessful during initialization. Unable to deploy and verify the vProxy my-proxy.my-domain.com. Unable to query vProxy status after 'Deploy'. Request unsuccessful. Unable to resolve External vproxy 'my-proxy.my-domain.com' IP address in DNS server(s).)
Cause
The PowerProtect Appliance does not have access to the VM Direct Engine over port 9090.
admin@ppdm:~> curl -v my-proxy.my-domain.com:9090 * Trying 192.168.9.131:9090... * connect to 192.168.9.131 port 9090 failed: No route to host * Failed to connect to my-proxy.my-domain.com port 9090 after 18548 ms: Couldn't connect to server * Closing connection 0 curl: (7) Failed to connect to my-proxy.my-domain.com port 9090 after 18548 ms: Couldn't connect to server admin@ppdm:~>
Resolution
The environment firewall or networking must be configured to allow the PowerProtect Appliance to communicate to the VM Direct Engine over ports 22 and 9090.
Article Properties
Article Number: 000399113
Article Type: Solution
Last Modified: 19 Dec 2025
Version: 2
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