PowerEdge: HBA355, HBA350, or HBA345 on ESXi server shows purple screen or multiple drives missing
Summary: An ESXi server or a node that is part of a vSAN cluster may report purple screen with the message "…disk name: naa.5000xxxxxxxxx detected suspended I/Os…" or may report all drives that are attached to an HBA are missing. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Note: For VxRail-based units, see Dell KB article: Dell VxRail: HBA355 lsi-msgpt35 Driver Version 18.00.01.00 and Earlier May Cause a Purple Screen or Drives Missing for the supported resolution.
Symptoms:
An ESXi server shows a purple screen with the message "disk name: naa.5000xxxxxxxxx detected suspended I/Os" or may report all drives that are attached to an HBA are missing.
It can result in any or all the following issues:
- Drives not detected in the operating system
- System sluggishness
- Purple screen or crash
This condition occurs every 49 days of uptime when using a lsi-msgpt35 driver running version before 19.00.03.00.
Cause
The HBA driver in ESXi is not waiting to complete some commands that are issued when the system uptime reaches a specific window (every 49 days 17 hours 2 min 47.295 seconds). When system uptime has reached this window or any multiple of it, any driver command may be treated as a timeout. Command timeout recovery methods from the driver also fail if issued within this window, and the HBA may lose communication with all attached drives.
There is a small window (a few milliseconds) when this issue can present itself every 49 days 17 hours 2 min 47.295 seconds of uninterrupted uptime.
There is a small window (a few milliseconds) when this issue can present itself every 49 days 17 hours 2 min 47.295 seconds of uninterrupted uptime.
Resolution
Issue is addressed with updated LSI driver version 19.00.03.00 and later.
Download ESXi driver version 19.00.03.00 from the Broadcom ESXi Drivers Page
For VxRail and VCF on VxRail solutions, see Dell KB article 197362: Dell: VxRail - HBA355 lsi-msgpt35 driver version 18.00.01.00 and older may cause PSOD or drives missing.
Affected Products
HBA345, HBA350i, HBA355, VMware ESXi 6.7.X, VMware ESXi 7.xProducts
VMware VSANArticle Properties
Article Number: 000197362
Article Type: Solution
Last Modified: 29 Apr 2025
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.