NVE: Auf die Webseite des NetWorker-Installationsmanagers kann nicht zugegriffen werden

Summary: Die Webseite von NetWorker Virtual Edition (NVE) Installation Manager (AVI) ist nicht zugänglich. In diesem Wissensdatenbank-Artikel wird beschrieben, wie Sie potenzielle Ursachen beheben und identifizieren können. ...

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Symptoms

Der NetWorker-Server ist eine NetWorker Virtual Edition (NVE).

Auf die Webseite des Installationsmanagers (AVI) kann nicht zugegriffen werden.

Die NVE-Webschnittstelle ist mit Fehler 503 nicht verfügbar.
Abbildung 1: Die NVE-Webschnittstelle ist mit Fehler 503 nicht verfügbar.

Die Spalte avinstaller Service wird nicht ausgeführt:

NVE:~ # avinstaller.pl --test
Avistart process:
INFO: AVI is not running.

Cause

Der Installationsmanager (AVI) avinstaller Der Prozess wird nicht ausgeführt.

Resolution

  1. Stellen Sie über SSH eine Verbindung mit der NVE her als admin.
  2. Wechseln Sie zum root Konto:
sudo su -
    1. Stellen Sie sicher, dass die NVE keine vollständigen Partitionen aufweist:
    df -Th

    Die Spalte /data01 Partition kann erweitert werden: NetWorker Virtual Edition: Erhöhen der Partitionsgröße /data01

    Die Spalte / (root) Partition kann nicht erweitert werden. Prüfen Sie, ob Dateien Speicherplatz beanspruchen, und verschieben Sie sie an einen anderen Speicherort oder entfernen Sie sie. Mit dem folgenden Befehl können Dateien identifiziert werden, die größer als 100 MB sind:
    find / -size +100M -type f
    Suchen Sie nach großen Dateien direkt auf der Registerkarte / (SDA3-Gerät) Die folgenden Dateitypen können entfernt werden:
    • .log
    • .raw
    • .tgz
    1. Wenn es keine Speicherplatzprobleme auf der NVE gibt, starten Sie die avinstaller Dienst:
    avinstaller.pl --start

    Alternativ kann der folgende Befehl verwendet werden, um den Service zu starten, während Debug-Meldungen angezeigt werden:

    avinstaller.pl --debug
    1. Vergewissern Sie sich, dass das avinstaller hat begonnen:
    avinstaller.pl --test
    
    1. Stellen Sie eine Verbindung zur NVE-Webschnittstelle her. https://NVE-HOSTNAME
    HINWEIS: Wenn auf die Installationsmanager-Webseite nicht zugegriffen werden kann, vergewissern Sie sich, dass der Port überwacht wird und vom Host aus erreichbar ist.
    1. Überprüfen Sie, ob das avainstaller Port (7543) überwacht die NVE:
    netstat -apno | grep 7543
    Beispiel:
    nve:~ # netstat -apno | grep 7543
    tcp        0      0 :::7543                 :::*                    LISTEN      14411/java          off (0.00/0/0)
    nve:~ #
    nve:~ # ps -ef | grep 14411
    root      6329  6147  0 14:47 pts/1    00:00:00 grep --color=auto 14411
    avi      14411     1  0 Mar27 ?        00:04:54 java -Xmx1g -server -Djava.security.egd=file:/dev/./urandom -Dsecurity.provider.rsa.JsafeJCE.position=last -Djavax.net.ssl.trustStore=/usr/local/avamar/lib/avi/avi_keystore -Djavax.net.ssl.keyStore=/usr/local/avamar/lib/avi/avi_keystore -Xdebug -agentlib:jdwp=transport=dt_socket,address=9999,server=y,suspend=n -jar /usr/local/avamar/lib/jetty/avistart.jar
    HINWEIS: Im obigen Befehl zeigt Port 7543 "LISTEN" an, was darauf hinweist, dass die avinstaller ausgeführt wird und der Port auf Anforderungen wartet. Die Spalte netstat listet auch die Prozess-ID (PID) der avinstaller an. Mithilfe des Befehls ps -ef wird die PID mit der avinstaller an.
    1. Vergewissern Sie sich, dass die NVE eine Verbindung zum avinstaller Lokal verarbeiten:
    curl -v localhost:7543
    Beispiel:
    nve:~ # curl -v localhost:7543
    *   Trying 127.0.0.1:7543...
    * Connected to localhost (127.0.0.1) port 7543 (#0)
    > GET / HTTP/1.1
    > Host: localhost:7543
    > User-Agent: curl/8.0.1
    > Accept: */*
    >
    * Received HTTP/0.9 when not allowed
    * Closing connection 0
    curl: (1) Received HTTP/0.9 when not allowed
    1. Von dem Host, der für den Zugriff auf die avinstaller Webnutzeroberfläche bestätigen, dass Sie die NVE-Adresse auflösen können, und stellen Sie eine Verbindung zum avinstaller Anschluss: Dies kann über die tnc Befehl von PowerShell:
    tnc NVE_ADDRESS -p 7543
    Beispiel:
    TNC-Beispiel
     
    HINWEIS: Wenn die avinstaller Der Prozess ist empfangsbereit, aber Sie können die NVE nicht auflösen oder eine Verbindung zum Port von einem Remotehost herstellen. Das Problem liegt außerhalb von NetWorker. Stellen Sie sicher, dass der Host, der für den Zugriff auf avinstaller kann den NVE-Namen auflösen oder die IP-Adresse für den Zugriff auf die Avinstaller-Benutzeroberfläche verwenden. Auf die IP-Adresse muss von dem Host aus zugegriffen werden können, der für den Zugriff auf die Benutzeroberfläche verwendet wird. Wenn die Namensauflösung funktioniert, aber die Verbindung zu Port 7543 fehlschlägt, wenden Sie sich bezüglich dieser Verbindung an Ihr Netzwerk- oder Sicherheitsteam. Dieser Port ist erforderlich, um auf die zuzugreifen avinstaller BENUTZEROBERFLÄCHE. Alternativ können Sie auf die avinstaller UI von einem anderen Host, der auf Port 7543 auf der NVE zugreifen kann.

    Additional Information

    Wenn die Installationsmanager-Webseite nicht gestartet werden kann oder nicht ordnungsgemäß funktioniert, überprüfen Sie die folgenden Protokolle:

    • /usr/local/avamar/lib/jetty/logs/
    • /space/avamar/var/avi/server_log/
    • /var/log/messages

    Weitere Artikel:

    Affected Products

    NetWorker

    Products

    NetWorker Family, NetWorker Series
    Article Properties
    Article Number: 000213100
    Article Type: Solution
    Last Modified: 10 Nov 2025
    Version:  9
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