NetWorker: smtpmail does not support authentication to SMTP server
Summary: NetWorker server uses its own smtpmail command. However, it does not currently support specifying a username and password to connect to an SMTP server that requires this authentication to relay mails. ...
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Symptoms
NetWorker server is configured to use smtpmails within policies, workflows, and other types of notifications.
The mail however is not received on the mail server.
The SMTP mail server is configured with Authentication, but smtpmail command options do not provide syntax options to add a username and password.
When manually testing smtpmai command, it fails:
C:\> smtpmail -h mail.server.com -s subject sender@sender.com 0 1711515859 2 0 0 20288 10440 0 nwserver smtpmail NSR warning 2 %s 1 0 115 protocol failure; got 550 5.7.1 <sender@sender.com>... we do not relay SYSTEM@nwserver
Cause
NetWorker's smtpmail does not work with username and password, and cannot send mails to an SMTP server if authentication is required.
Resolution
As of now, there is no resolution to this issue rather than either:
- Use a non-authenticated SMTP server
- Allow NetWorker server IP to bypass the authentication.
RFE NW-I-1925 was opened to request that this feature be in NetWorker. There is not ETA nor confirmation whether this enhancement will be in any near future in NetWorker.
Affected Products
NetWorkerArticle Properties
Article Number: 000223676
Article Type: Solution
Last Modified: 26 Apr 2024
Version: 2
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