Dell NativeEdge Onboard Edge Orchestrator 2.2.0.0 fails to use Static IP

Summary: Onboarding Edge Orchestrator 2.2.0.0 fails when setting a static IP by service console.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

For NativeEdge Orchestrator 2.2.0.0, when customers use a static IP by the service console to onboard endpoints to Edge Orchestrator, after the endpoints OS reboots into EdgeOS, it loses connections to Edge Orchestrator and the onboarding process does not complete. The issue only occurs when there is an entry in the service console file during onboarding.

On the user interface, you can see State as "Not reachable" and Provisioning State stuck at "Provisioning Operating Environment" while the endpoints successfully boot into EdgeOS. 

Screenshot 2024-11-07 172111.png

Cause

The DNS entries received through the service console are not set properly, causing the endpoint to be unable to resolve the Orchestrator address/FQDN.

 

Resolution

NativeEdge Engineering has created a dedicated hotfix to address the issues described above.


After applying the hotfix, the DNS entries are set correctly on the host network interface so that the endpoint can resolve the address and connect to the Orchestrator. 


Contact Dell Support Services to allocate a hotfix bundle to fix the issue.

Affected Products

NativeEdge Solutions, NativeEdge
Article Properties
Article Number: 000245559
Article Type: Solution
Last Modified: 07 Nov 2024
Version:  1
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