Dell NativeEdge Onboard Edge Orchestrator 2.2.0.0 fails to use Static IP
Summary: Onboarding Edge Orchestrator 2.2.0.0 fails when setting a static IP by service console.
Symptoms
For NativeEdge Orchestrator 2.2.0.0, when customers use a static IP by the service console to onboard endpoints to Edge Orchestrator, after the endpoints OS reboots into EdgeOS, it loses connections to Edge Orchestrator and the onboarding process does not complete. The issue only occurs when there is an entry in the service console file during onboarding.
On the user interface, you can see State as "Not reachable" and Provisioning State stuck at "Provisioning Operating Environment" while the endpoints successfully boot into EdgeOS.

Cause
The DNS entries received through the service console are not set properly, causing the endpoint to be unable to resolve the Orchestrator address/FQDN.
Resolution
NativeEdge Engineering has created a dedicated hotfix to address the issues described above.
After applying the hotfix, the DNS entries are set correctly on the host network interface so that the endpoint can resolve the address and connect to the Orchestrator.
Contact Dell Support Services to allocate a hotfix bundle to fix the issue.