Avamar - How to retrieve the system_info area files from an Avamar backup

Summary: In this article you will find the steps to retrieve the system_info area files from an Avamar backup

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

In some cases, during Avamar Backup/Restore troubleshooting, we need to retrieve a backup info metadata - system_info area files.

Cause

Avamar saves the entire backup information for a specific backup in the gsan component along with the backups in the .system_info directory

 

Each backup will contain a '.system_info' directory

 

The following information is available in the '.system_info' directory.

  • 1. Entire session Log
  • 2. Work Order
  • 3. The filesystems of the client being backed up
  • 4. Backup statistics log for the session
  • 5. File statistics
  • 6. errors along with error code

 

Resolution

To extract the '.system_info' directory, restore the backup metadata directory using the syntax:

From any system with access to the Avamar server, in this example it is from a Windows PC:
  • avtar.exe -x --server=<Avamar server FQDN or IP> --id=<MC user name> --ap=<MC user's password> --path=<domain>/<client name> --labelnum=<Label number> --target=<Path at local disk> ".system_info" --internal

     
Example directly connected to the Utility node via SSH:
  • avtar -x --path=<domain>/<client name> --labelnum=<Label number> --target=./​​​​​ .system_info --internal

Notes:

  • If a backup label is not specified the '.system_info' directory of the latest backup is extracted.
  • Since the directory is hidden, we need to use the --internal flag to restore it as shown above.

 

The following files will be restored into the target path once the '.system_info' directory is restored:

-rw-r--r--  1 admin admin   1376 Nov  3 15:15 archive_info
-rw-r--r--  1 admin admin   4272 Nov  3 15:15 archive_info.xml
-rw-r--r--  1 admin admin    295 Nov  3 15:15 encodings.xml
-rw-r--r--  1 admin admin    100 Nov  3 15:15 errors
-rw-r--r--  1 admin admin  15835 Nov  3 15:15 filestats
-rw-r--r--  1 admin admin    175 Nov  3 15:15 groups
-rw-r--r--  1 admin admin    282 Nov  3 15:15 locale.xml
-rw-r--r--  1 admin admin   1221 Nov  3 15:15 machine.xml
-rw-r--r--  1 admin admin 262144 Nov  3 15:15 mbr0.bin
-rw-r--r--  1 admin admin      0 Nov  3 15:15 mounts
-rw-r--r--  1 admin admin    271 Nov  3 15:15 partitiontables.xml
-rw-r--r--  1 admin admin  11889 Nov  3 15:15 sessionlog
-rw-r--r--  1 admin admin  82666 Nov  3 15:15 statsfile
-rw-r--r--  1 admin admin    243 Nov  3 15:15 users
-rw-r--r--  1 admin admin   8192 Nov  3 15:15 vbr0-0.bin
-rw-r--r--  1 admin admin   1088 Nov  3 15:15 volumes.xml
-rw-r--r--  1 admin admin   2860 Nov  3 15:15 workorder


 

    Additional Information

    Some utility of the information contained in the .system_info directory:

    • The session log can be used to troubleshoot if the logs from the client machine are not available/accessible.
    • The same can be used along with the work order details to resolve issues.
    • The file stats and the backup stats can be used to troubleshoot slow backups
    • The file system files [such as volumes.xml, machine.xml, partitiontables.xml, CriticalVolumeMapping.xml, BackupComponentsDocument.xml] contain information that can be used to re-create clients in the case of DR Restore (BMR).

    Affected Products

    Avamar
    Article Properties
    Article Number: 000102778
    Article Type: Solution
    Last Modified: 28 May 2023
    Version:  5
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