Excessive Hard Drive Free Space Decreasing Over Time on Dell Computers

Summary: Learn what to do if Dell computers running Windows 10 or 11 experience a reduction in available free space on the hard drive over time.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The used space on a hard drive may increase over time on a Dell computer that is running Windows 10 or Windows 11. This causes the hard drive to lose available free space. This can occur within days, weeks, or months depending on the size of the hard drive and the amount of stored data. When experiencing an unusual amount of hard drive storage, it is observed that Windows System Protection settings changed automatically. The Max Usage slider shows that it has automatically moved to 100%.

Access the Windows System Protection settings by searching in the Windows search bar for View Advanced System Settings and then opening it. Go to the System Protection tab and then click the Configure button.
System Protection tab and Configure button

The Windows System Protection Disk Space Usage - Max Usage slider has moved from 0% to 100%.
Disk Space Usage - Max Usage slider 100%

This change impacts the Current Usage bytes by going from 0 bytes to an increasing hard drive storage amount. To further explain this, see the below example image showing a Before symptom with 0 bytes. In this example image, system protection is disabled.
Before example, system protection disabled

Compare the above Before symptom with the After symptom example image, below, showing a Dell computer with max usage at 100%.
After example, max usage jumped to 100%

When the Windows System Protection Disk Space Usage - Max Usage slider goes to 100%, the hard drive free space continues to decrease over time. A degradation in performance may be noticed.

Cause

The root cause of the issue is that the MaxSize parameter of the Windows Volume Shadow Copy Service (VSS) is not initially set.

Not having MaxSize initially set leaves the VSS in an "undefined" state, causing it to inadvertently become unbounded when an application like Dell SupportAssist OS Recovery attempts to read VSS data. As a result, the Windows System Protection Settings forces the Disk Space Usage Max Usage Slider to 100%. This mirrors the unlimited amount of Volume Shadow Copies and ultimately fills up the computer’s hard drive space.

Resolution

There are two options that the user can follow to resolve the issue of hard drive free space decreasing over time. Customers must only choose one option.

Option 1: Set the Windows System Protection Disk Space Usage Max Usage Slider to 2%

  1. In the Windows search bar, search and then open View Advanced System Settings.
  2. Go to the System Protection tab and then click the Configure button.
    System Protection tab and Configure button
  3. Click the Delete button to delete all restore points for this drive (Figure 6).
  4. Move the Max Usage Slider to 2%.
  5. Click the OK button to save the changes.
    Deleting all restore points and setting Max Usage to 2%

Option 2 (Advanced Users): Change the VSS MaxSize parameter from unbounded to 2%

The VSS MaxSize parameter can be set by opening an administrative Command Prompt window and typing in the following command:

vssadmin resize shadowstorage /For=C: /On=C: /MaxSize=2%

Setting the VSS MaxSize parameter to 2%

Press Enter after typing the command and then read the response to confirm that the changes are successful. A response stating, "Successfully resized the shadow copy storage association" confirms success.

Affected Products

SupportAssist for Home PCs, SupportAssist OS Recovery, SupportAssist for Business PCs
Article Properties
Article Number: 000129138
Article Type: Solution
Last Modified: 19 Apr 2025
Version:  8
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