Boot Manager Not Found On First Reboot After an MDT Install Using UEFI
Summary: Information about fixing a "Boot Manager Not Found" error after a Microsoft Deployment Toolkit (MDT) install using Unified Extensible Firmware Interface (UEFI).
Symptoms
Boot Order Change
If you get an error while deploying Windows 10 using:
- Microsoft Deployment Toolkit Version 8443
- Windows 10 ADK 1703 or 1709
While the target computers are using UEFI firmware.
After booting in WinPE and do the install phase (Apply Operating System), the computer is booting again on Network/USB disk instead of using UEFI Firmware (Bootmgfw.efi).
Cause
Due to changes to optimize bcdboot tools, MDT 8443 is not using the right bcdboot command line from Windows 10 1703 / 1709 ADK to update the UEFI firmware boot order. This problem has been raised to the MDT Product Team and should be fixed for the next release of MDT later this year.
Resolution
Edit Deployment Scripts
On your deployment share, go to the Scripts folder.
Backup LTIApply.wsf.
Open LTIApply.wsf with your text editor and replace the following line:
TestAndFail RunBCDBootEx( sDestinationDrive & "\windows", " /s " & left(oBootDrive.Drive,2) & " /f UEFI"), 5616, "Verify BCDBootEx"
With this line:TestAndFail RunBCDBootEx( sDestinationDrive & "\windows", " /c"), 5616, "Verify BCDBootEx"
More information: /c Optional. Specifies that any existing BCD elements should not be migrated. New for Windows 10: By default, during an upgrade, BCD elements such as debugsettings or flightsigning are preserved.
BCDBoot Command-Line Options
MDT v. 8443 + ADK v. 1703 = boot-order changed after Post Install using UEFI