Avamar: SQL AlwaysOn-klynge mislykkes

Summary: Denne KB-artikkelen drøfter en løsning for å løse Strukturert Spørringsspråk (SQL) AlwaysOn (AO)-klyngebla og sikkerhetskopieringsfeil på grunn av nettverksrelaterte eller forekomstspesifikke feil når SQL AlwaysOn-klyngen er konfigurert til å lytte på en port som ikke er standard. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

SQL AlwaysOn (AO)-klyngen kan mislykkes i å bla gjennom eller sikkerhetskopiere med en feilmelding som ligner på følgende:
 

avsql Error <9072>: sqlconnectimpl_smo::connect Microsoft.SqlServer.Management.Common.ConnectionFailureException: Failed to connect to server EMClistener. ---> System.Data.SqlClient.SqlException: A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server) ---> System.ComponentModel.Win32Exception: The system cannot find the file specified
 

Cause

SQL AO-lytteren er konfigurert til å lytte på en port som ikke er standard. Som standard er den konfigurert til å lytte på TCP-port 1433.

Resolution

Opprett en avsql.cmd fil i den delte Var-mappen som er angitt for tilgjengelighetsgruppen Avamar SQL AlwaysOn, og legg til følgende flagg: 

--sqlserver=<availability group listener's IP address>,<listener port>


Eksempel:  

--sqlserver=172.1.1.1,5123


Du finner IP-adressen og porten som er konfigurert for AO-lytterporten, ved å gå til SQL Server Management Studio:

SQL Always On – SQL-lytterkonfigurasjon

Affected Products

Avamar, Avamar Plug-in for SQL
Article Properties
Article Number: 000162984
Article Type: Solution
Last Modified: 23 Sept 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.