PPDP: IDPA Search Component Fails if Files From Previous Upgrade Remain in /etc/puppet/status/

Summary: Integrated Data Protection Appliance upgrade fails for Search component at ~55% due to older upgrade files left behind in the status directory.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

/etc/puppet/status/ should not have any files in it, which happens during upgrade. It may not have been cleaned up properly from the previous upgrade, so content should be removed if found before the upgrade starts.

Log in to Search as root user and run:

ls -la /etc/puppet/status/

If this returns any files in that folder, they must be removed:

rm -rf /etc/puppet/status/*

If this is not caught before an upgrade begins, the workflow fails. As an example:

  • ACM reports Search has failed at 55%.
  • In /data01/tmp/patch/logs/dps_upgrade.log
15/07/22 15:30:05 run_cmd_dps_output() Cmd:ls -l /etc/puppet/status/
15/07/22 15:30:05 run_cmd_dps_output() total 12
15/07/22 15:30:05 run_cmd_dps_output() drwxr-xr-x 2 root root 4096 Nov 22 2021 19.5.0.3728
15/07/22 15:30:05 run_cmd_dps_output() -rw-r--r-- 1 root root 103 Nov 22 2021 search-upgrade-19.5.0.3728.zip-allcompleted
15/07/22 15:30:05 run_cmd_dps_output() -rw-r--r-- 1 root root 92 Nov 22 2021 search-upgrade-19.5.0.3728.zip-completed
15/07/22 15:30:05 run_cmd_dps_output() Status: 0
15/07/22 15:30:05 run_cmd_dps_output() Cmd:cat /usr/local/search/version
15/07/22 15:30:05 run_cmd_dps_output() 19.5.0.3728
15/07/22 15:30:05 run_cmd_dps_output() Status: 0
15/07/22 15:30:05 check_search_version_on_master() 19.5.0.3728
15/07/22 15:30:05 check_search_version_on_master() Could not verify Search version

Cause

ACM uses /etc/puppet/status/ directory to monitor upgrade status in the Search component. If any files are left behind from previous upgrades, ACM upgrade logic does not know how to proceed. The workflow fails at ~55%.

Resolution

When the Retry button in ACM is clicked, it rollbacks to the BeforeUpgrade VM snapshot taken in vCenter, and undoes any changes that were made. Therefore, the Retry button must be clicked to allow the rollback, only taking these next steps after the VM is available again.
 

Note: A fix for this issue has been added to the GoIDPA tool. Follow the below article to install the GoIDPA tool: PowerProtect Data Protection Appliance: GoIDPA tool

Run the following command on the ACM:
./goidpa dpsearch clean-upgrade-files

Contact Dell Support if any assistance is required here.

Once the rollback to BeforeUpgrade snapshot is completed and Search VM is available again, log in using root user and remove all files from /etc/puppet/status/ with the following command:

rm -rf /etc/puppet/status/*

This allows the workflow to proceed, and the upgrade should complete as intended.

Affected Products

PowerProtect Data Protection Software, Integrated Data Protection Appliance Family, Integrated Data Protection Appliance Software
Article Properties
Article Number: 000201735
Article Type: Solution
Last Modified: 15 May 2025
Version:  9
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