PowerStore: Deleting the File System Which Was Created by IMT Did Not Complete

Summary: Deleting the file system which was created by IMT did not complete.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

During import of the NAS server from Legacy Dell source storage system to PowerStore storage system, the NAS server, file system, and its related objects get synced. During Cancel, the same object gets deleted in the target. If Cancel did not complete during import due to some reason, the user may see message "Object identifier not found."

User sees error as below:
 
Screenshot of Error Message "Object Identifier Not Found" in PowerStore
Figure 1: Screenshot of Error Message "Object Identifier Not Found" in PowerStore

Cause

The file system and its related object could not be deleted.

Resolution

Manual intervention is required to delete the file system if it is not automatically deleted.

Log in to PowerStore CLI and use the REST API command to fetch the FS name:
curl -s -X GET http://[{cluster ip}]:3085/api/instances/filesystem/{id}
With this output, user can delete the relevant FS in PowerStore Manager.

Affected Products

PowerStore
Article Properties
Article Number: 000201906
Article Type: Solution
Last Modified: 12 Jun 2023
Version:  2
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