PowerStore: База даних Dell SupportAssist може заповнитися, і /cyc_node/ (внутрішній розділ), що призводить або до збою NDU, або перезавантаження вузла
Summary: Пристрої PowerStore, підключені до SupportAssist, можуть стикатися з ситуаціями, коли база даних SupportAssist стає надто великою, що може заважати здійсненню оновлень.
Symptoms
Це може призвести до проблем із місцем на одному з внутрішніх розділів (/cyc_node), що може заважати виконанню оновлень або призвести до перезавантаження вузла.
Ця проблема може виникати на кластерах із незвично великою кількістю сповіщень, через що база даних стає надто великою.
Спроби оновлення PowerStoreOS зазнають невдачі через помилку, яка свідчить про недостатній простор на /cyc_node для оновлення.
Cause
SupportAssist створює запис бази даних для кожного файлу, завантаженого до SupportAssist, і не має механізму для старіння цих записів. Якщо система генерує багато сповіщень, база даних може швидко зростати.
Приклади командних виходів:
[SVC:service@*******-* ~]$ df -hT /cyc_node Filesystem Type Size Used Avail Use% Mounted on /dev/md106 ext4 738M 497M 189M 73% /cyc_node
І
[SVC:service@*******-* ~]$ ls -lh /cyc_node/service/eve/hostmnt_config/opt/ese/var/run/ese/ese.db -rw-r--r-- 1 1100 1001 200M Sep 21 21:04 /cyc_node/service/eve/hostmnt_config/opt/ese/var/run/ese/ese.db
Поширені сценарії, пов'язані з цим сповіщеннем, такі, і їх можна розглянути за допомогою svc_partition_cleanup service Сценарій:
- Стаття # 000198173 PowerStore: Перевірка здоров'я системи виявляє нестачу місця в cyc_node
- Стаття # 000202707 PowerStore: Перевірка здоров'я перед оновленням провалюється через нестачу місця в /cyc_cfs
- Стаття # 000193605 PowerStore: Збір даних не вдається, і інтерфейс користувача PowerStore Manager повідомляє про ненормальну інформацію
- Стаття # 000324110 Сповіщення PowerStore: Використання кореневого розділу вузла X перевищило 91 відсоток на монтуванні /.
- Стаття # 000202949 PowerStore: База даних Dell SupportAssist може заповнитися, і /cyc_node/ (внутрішній розділ), що призводить або до збою NDU, або перезавантаження вузла
- Стаття # 000223342 PowerStore: Періодичні коди тривоги 0x00400601 та 0x00400602 для монтування /cyc_node
- Стаття # 000328471 PowerStore: Використання кореневих розділів швидко зростає
Resolution
Переважна більшість причин, що призводять до повного розділу, була вирішена в PowerStoreOS LTS-v4.1.x.
Після вирішення поточної проблеми оновіть пристрій PowerStore до PowerStoreOS LTS-v4.1.x або вище.
ОБХІДНИЙ ШЛЯХ:
Переключіть функцію SupportAssist, щоб очистити зайві файли на монтуванні /cyc_node.
- У інтерфейсі PowerStore перейдіть у розділ Налаштування > підтримки підключення > типу підключення
- Зверніть увагу на відображену конфігурацію, оскільки деталі потрібно ввести знову на наступному етапі
- Натисніть, щоб вимкнути
- Натисніть «Подати заявку» внизу сторінки
- Коли робота, здається, завершена, оновіть сторінку інтерфейсу, щоб переконатися, що функція вимкнена
- Якщо після оновлення сторінки інтерфейсу з'являється вимкнено, продовжуйте крок 2
- Якщо він залишається увімкненим після двох спроб, зверніться до технічної підтримки Dell або до вашого уповноваженого сервісного представника та зверніться за цим ідентифікатором цієї статті
- Зачекай 15 хвилин
- Увімкніть SupportAssist з оригінальними деталями конфігурації, зафіксованими раніше
- Коли робота, здається, завершена, оновіть сторінку інтерфейсу, щоб переконатися, що функція увімкнена
- Якщо проблеми залишаються, використовуйте скрипт svc_partion_cleanup сервісу для дослідження та очищення кореневих розділів.
- Загальні інструкції з монтажу: KB# 000371058 PowerStore: Як встановити svc_injectable сервісні скрипти 000371058 PowerStore: Як встановити svc_injectable сервісні скрипти (для перегляду цієї статті може знадобитися увійти як зареєстрований користувач Dell Support.)
- svc_partition_cleanup Процедура: KB# 000214954 PowerStore: Як запустити ін'єкційний сервісний скрипт svc_partition_cleanup для очищення розділів /cyc_node, /cyc_var та /cyc_cfs (Для перегляду цієї статті може знадобитися увійти як зареєстрований користувач Dell Support.)
Якщо проблеми залишаться або повертаються, звертайтеся до Технічної підтримки за допомогою.
Посилання на KB# 000202949 для прискореного обслуговування.