PowerStore: Dell SupportAssist-databasen kan fylles opp og føre til at /cyc_node/ (en intern partisjon) er full, noe som forårsaker enten NDU-feil eller omstart av node
Summary: PowerStore-apparater som er koblet til SupportAssist, kan oppleve scenarier der SupportAssist-databasen (db) blir for stor, noe som kan forstyrre muligheten til å utføre oppgraderinger. ...
Symptoms
Dette kan føre til plassproblemer på en av de interne partisjonene (/cyc_node), som kan forstyrre muligheten til å utføre oppgraderinger eller føre til omstart av en node.
Dette problemet kan oppstå på klynger som har et uvanlig stort antall varsler, noe som fører til at db blir for stor.
Forsøk på å oppgradere PowerStoreOS mislykkes med en feilmelding som tyder på at det ikke er nok plass på /cyc_node til å fortsette med oppgraderingen.
Cause
SupportAssist oppretter en databaseoppføring for hver fil som lastes opp til SupportAssist, og har ingen mekanisme for å aldre disse oppføringene. Hvis systemet genererer mange varsler, kan databasen vokse raskt.
Eksempel på kommandoutdata:
[SVC:service@*******-* ~]$ df -hT /cyc_node Filesystem Type Size Used Avail Use% Mounted on /dev/md106 ext4 738M 497M 189M 73% /cyc_node
og
[SVC:service@*******-* ~]$ ls -lh /cyc_node/service/eve/hostmnt_config/opt/ese/var/run/ese/ese.db -rw-r--r-- 1 1100 1001 200M Sep 21 21:04 /cyc_node/service/eve/hostmnt_config/opt/ese/var/run/ese/ese.db
Vanlige scenarier knyttet til dette varselet er som følger, og kan håndteres med svc_partition_cleanup service skript:
- Artikkel # 000198173 PowerStore: Systemtilstandskontroller oppdager plassmangel i cyc_node
- Artikkel # 000202707 PowerStore: Tilstandskontroll før oppgradering mislykkes på grunn av plassmangel i /cyc_cfs
- Artikkel # 000193605 PowerStore: Datainnsamlingen mislykkes, og brukergrensesnittet for PowerStore Manager rapporterer unormal informasjon
- Artikkel # 000324110 PowerStore-varsler: Rotpartisjonsbruken til node X har oversteget 91 prosent på montering /.
- Artikkel # 000202949 PowerStore: Dell SupportAssist-databasen kan fylles opp og føre til at /cyc_node/ (en intern partisjon) er full, noe som forårsaker enten NDU-feil eller omstart av node
- Artikkel # 000223342 PowerStore: Periodiske varslingskoder 0x00400601 og 0x00400602 for montering /cyc_node
- Artikkel # 000328471 PowerStore: Rotpartisjonsbruken øker raskt
Resolution
De aller fleste årsaker som fører til full partisjon erløst i PowerStoreOS LTS-v4.1.x.
Når du har løst gjeldende tilstand, oppdaterer du PowerStore-verktøyet til PowerStoreOS LTS-v4.1.x eller nyere.
LØSNING:
Sykle SupportAssist-funksjonen for å fjerne fremmede filer på /cyc_node-monteringen.
- Fra PowerStore-grensesnittet går du til Innstillinger > Støtte for tilkoblingstype >
- Legg merke til konfigurasjonen som vises, siden detaljene må angis på nytt i et senere trinn
- Klikk for å deaktivere
- Klikk på Bruk nederst på siden
- Når jobben ser ut til å være fullført, oppdaterer du brukergrensesnittsiden for å bekrefte at funksjonen er deaktivert
- Hvis den vises deaktivert etter en oppdatering av brukergrensesnittsiden, fortsetter du til trinn 2
- Hvis den fortsatt er aktivert etter to forsøk, kontakter du Dells tekniske støtte eller din autoriserte servicerepresentant og refererer til denne artikkel-ID-en
- Vent 15 minutter
- Aktiver SupportAssist med den opprinnelige konfigurasjonsinformasjonen som ble tatt fra tidligere
- Når jobben ser ut til å være fullført, oppdaterer du brukergrensesnittsiden for å bekrefte at funksjonen er aktivert
- Hvis problemene vedvarer, kan du bruke svc_partion_cleanup-tjenesteskriptet til å undersøke og rydde opp i rotpartisjonene.
- Generelle installasjonsinstruksjoner: KB# 000371058 PowerStore: Slik installerer du svc_injectable tjenesteskript 000371058 PowerStore: Slik installerer du svc_injectable tjenesteskript (Du må kanskje logge på som registrert Dell-kundestøttebruker for å lese denne artikkelen.)
- svc_partition_cleanup Fremgangsmåte: KB# 000214954 PowerStore: Slik kjører du det injiserbare tjenesteskriptet svc_partition_cleanup å rydde opp i partisjonene /cyc_node, /cyc_var og /cyc_cfs (Du må logge på som registrert Dell-støttebruker for å lese denne artikkelen.)
Kontakt teknisk støtte for å få hjelp hvis problemene vedvarer eller kommer tilbake.
Referanse KB# 000202949 for rask service.