PowerStore: RSC does not function after NDU

Summary: After upgrading PowerStore software, RSC shows as enabled but RSC credentials do not work for Remote Access via SupportAssist.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Even though RSC has been enabled by the customer prior to the upgrade, Support/Services are unable to use RSC credentials to gain remote access to the PowerStore.  Regular SSH password still works, and operation of the system and SupportAssist functionality is otherwise unaffected.

This issue affects all PowerStore OS versions from 2.0 through 3.2.

Cause

The reinitialize of SupportAssist that occurs as part of the final steps of the upgrade ends up removing the supporting filesystems and recreating them, but there is a missing step in reinitiating RSC support.

Resolution

Disabling and reenabling SupportAssist will resolve the issue. It is recommended to wait 15 minutes before restarting to ensure that the SupportAssist was disabled.

If the issue persists, contact technical support for assistance.

Affected Products

PowerStore, PowerStoreOS

Products

SupportAssist
Article Properties
Article Number: 000203277
Article Type: Solution
Last Modified: 27 Jul 2023
Version:  5
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