ECS Service Console: "Validate Node hostname" "Check DNS Settings" Fail with Case Mismatch

Summary: ECS service-console check for "Validate Node hostname" or "Check DNS settings" fails due to case mismatch between domain name system (DNS) hostname.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Service Console logs an error when the hostname on a node does not match the name found in DNS. This check is case-sensitive.

The following error is logged for each node with a mismatch: 
20220101 12:00:00.000: Validate Node hostname
[ERROR] The hostname on node 169.254.1.1 is 'ecsnode01.dell.com' and the fqdn from the ini file is 'ECSNODE01.dell.com' - they do not match
There is a case-sensitive difference in the DNS setting checks and DNS results from the forward and backwards test. See in this example: ECSNODE01.dell.com vs ecsnode01.dell.com
20231108 09:31:22.270: |   | FAIL
[ERROR] 'Check DNS settings' failed: Could not find 'ECSNODE01.dell.com' in 'nslookup 10.0.0.1' output. Node: 169.254.1.1
10.0.0.1.dell.com = ecsnode1.dell.com.

Authoritative answers can be found from:

Cause

The ECS node hostnames must exactly match what is found in DNS. This includes both the Forward and Reverse lookup zones. This check is case-sensitive.

Resolution

Validate that the Forward and Reverse Zone DNS matches the hostname exactly. 

In this example the Forward and Reverse DNS only, differ by case-sensitive thereby generating an alert. 

In this example, the hostname is "ecsnode01.dell.com:" 

admin@ecsnode01:~> hostname -f
ecsnode01.dell.com

Check Forward DNS on the user's system using nslookup and the FQDN of the node: 

admin@ecsnode01:~> nslookup ecsnode01.dell.com
Server:         192.1xx.2xx.254
Address:        192.1xx.2xx.254#53

Non-authoritative answer:
Name:   ecsnode01.dell.com
Address: 10.0.0.1

In this example, the Forward DNS lookup matches the hostname. Both are all lowercase.

Check Reverse DNS on the user's system using nslookup and the IP address of the node:

admin@ecsnode01:~> nslookup 10.0.0.1
1.0.0.10.in-addr.arpa       name = ECSNODE01.dell.com.in-addr.arpa.

Authoritative answers can be found from:

In this example, the Reverse DNS lookup returns uppercase letters for the hostname. The Reverse DNS Zone should be updated to lowercase to match the hostname on the system. 

To resolve this issue, change the entries in the DNS server as the FQDN in ECS cannot be altered. This issue DNS should be updated so that it matches the hostname. Any mismatch between the hostname, the Forward DNS lookup, or the Reverse DNS lookup causes this error. 

User Action:
Article 80094: ECS: Is changing of the external or public name (FQDN) or the public IP address of an ECS node supported


If detected as a part of a preupgrade check:

20231107 12:51:45.771: |   Check DNS settings
20231107 12:51:46.248: |   | FAIL
[ERROR] 'Check DNS settings' failed: Could not find 'ECSNODE1.ch.net.intra' in 'nslookup 10.0.0.1' output. Node: 169.2xx.1.1
10.0.0.1.in-addr.arpa name = ecsnode1.ch.net.intra.

Authoritative answers can be found from:

It may be a false alert due to the case-sensitive difference and if it is only different regarding case-sensitive, then that does not block an upgrade.

Run the following checks for the node to check if it is a case-sensitive difference:

admin@ECSNODE1:~> hostname
ECSNODE1.ch.net.intra


admin@ECSNODE1:~> hostname -f
ECSNODE1.ch.net.intra


admin@ECSNODE1:~> hostname -i
10.0.0.1

admin@ECSNODE1:~> nslookup ECSNODE1
Server:         192.1xx.2xx.254
Address:        192.1xx.2xx.254#53

Non-authoritative answer:
Name:   ECSNODE1.ch.net.intra
Address: 10.0.0.1

admin@ECSNODE1:~> nslookup ecsnode1
Server:         192.1xx.2xx.254
Address:        192.1xx.2xx.254#53

Non-authoritative answer:
Name:   ecsnode1.ch.net.intra
Address: 10.0.0.1

admin@ECSNODE1:~> nslookup 10.0.0.1
1.88.96.10.in-addr.arpa name = ecsnode1.ch.net.intra.

Authoritative answers can be found from:

admin@ECSNODE1:~>

If the only difference detected is the letter case, then it is a false alert in the preupgrade check.

Affected Products

ECS, ECS Appliance
Article Properties
Article Number: 000203965
Article Type: Solution
Last Modified: 02 Jul 2025
Version:  11
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